2

I am using SuperPutty on Windows 10 to connect to the recently Upgraded RHEL server (from 6.X to 7.3 Maipo). One of my friends is getting strange â character in the output of the rm command after upgrade.

$ alias rm
rm='rm -i'
$ touch dummy_file.txt
$ rm dummy_file.txt
rm: remove regular empty file âdummy_file.txtâ?

Locale information:

$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

I don't know what could be causing this and my user doesn't have this issue.

  • 1
    Encoding/locale problems? It's probably trying to show pretty quotes “…”. Add the output of locale, please. – muru Mar 14 '18 at 5:58
  • $ locale LANG=en_US.UTF-8 LC_CTYPE="en_US.UTF-8" LC_NUMERIC="en_US.UTF-8" LC_TIME="en_US.UTF-8" LC_COLLATE="en_US.UTF-8" LC_MONETARY="en_US.UTF-8" LC_MESSAGES="en_US.UTF-8" LC_PAPER="en_US.UTF-8" LC_NAME="en_US.UTF-8" LC_ADDRESS="en_US.UTF-8" LC_TELEPHONE="en_US.UTF-8" LC_MEASUREMENT="en_US.UTF-8" LC_IDENTIFICATION="en_US.UTF-8" LC_ALL= Above is the output. Could you please advise, What do I need to do further to fix the issue? – Forever Learner Mar 14 '18 at 9:39
  • Is that the output of locale run by the user that has this issue or is it from your account? We need to see the output of the command run by the user having the problem. – terdon Mar 14 '18 at 10:05
  • Oh sorry terdon, it was output from my account. User is not here right now, I will update the outcome in couple of hours once he comes online. Thanks. – Forever Learner Mar 14 '18 at 12:27
  • 1
    In that case, maybe check Putty's settings. Maybe it's set to use a different encoding. – muru Mar 14 '18 at 14:17
1

we just found the solution. The issue was with Putty configuration. "SuperPutty -> Tools -> Putty Configuration -> Windows ->Translation -> Remote Char set" was set to ISO instead of UTF8. After we changed the Remote Char set to UTF8, issue is fixed. enter image description here Thanks muru and terdon for your inputs, it helped us in search in right direction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.