boot error screenshot

I used etcher to create a bootable usb drive and everything seemed to install fine. I'm in way over my head as far as how to go about even asking a question on what the problem is... I'm going to try reinstalling. Hopefully somebody sees this and instantly knows what my problem is. I formatted the flash drive as exfat and reinstalled and got to the home user selection screen the 2nd time. I used Etcher from my Mac.

2 Answers 2


Looks like a driver problem! No fear its fixable, but your going to need to get your hands dirty.

From some digging it appears the problem is linked to nvidia driver.


This would make sense since we can see from the output that many of your firmwares are failing, including wifi (iwlfwifi), bluetooth (ict), intel graphics (i915), and nvidia graphics card (nouveau). You can confirm this with the command lsmod | grep "name of firmware". If their is no output, the firmware is not loaded.

You could also try lspci and look for your network and graphics cards to see if they have the proper driver loaded.

This is a classic problem as debbian doesn't always play nice with drivers, especially those that it considers 'non-free' a.k.a. they don't adhere to the open source guidlines. 'Think free-speech, not free-beer' -RMS.

Here are some tips to help you get started fixing the problem:

1). boot up from the usb, mount your disks, and chroot into the system.

sudo mount /dev/sda2 /mnt
sudo cp /etc/resolv.conf /mnt/etc/resolv.conf
sudo chroot /mnt

2). edit your /etc/apt/sources.list to include non-free components.

sudo nano /etc/apt/sources.list

add contrib non-free to every repository line:

deb http://deb.debian.org/debian stretch main contrib non-free

3). update and upgrade

sudo apt-update && sudo apt-upgrade

4). If that does not work you may need to install the drivers manually. Start by determining your nvidia card via lspci. Then google the card to find the appropriate driver for debian linux and install it. This is a good place to start:


Once you have the correct firmware, you can unpack it and install it (assuming its a .tar.gz such as from the link provided) using:

cd ~/Downloads    
dpkg -i *

Firmware problems can be very frustarting, but are usually easy to solve once you figure out what is going on.

  • Thanks! I've been using a raspberry pi which is part of the reason I chose Debian, during the setup it asked if I wanted to load non free drivers from disk I thought it was just the wireless functionality (which I would be fine without) so I clicked no and continued. I tried an option called recover and some maintenance option came up asking for my root password. Journalctl -xb to see logs or something could I mount from that point?
    – Pfrex
    Mar 13, 2018 at 19:09

Ok, it was a driver issue I think. I ended up trying to install Ubuntu and found a bunch of articles on problems with nividia. I ended up changing the Ubuntu grub file to contain without the quotes "nouveau.modeset=0" again I'm pretty unsure of exactly what's going on here, but there is probably a similar way to get it to work on Debian. I guess I'll use Ubuntu though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .