0

When trying to set a higher resolution using xrandr, I get

Failed to get size of gamma for output default

Also lsmod | grep radeon returns no output meaning that the Radeon driver is not in use. According to this page, my graphics card is fully supported.

What I have tried so far:

  • After reading this, I tried to disable/removing my /etc/x11/xorg.conf but it didn't help.
  • Load video driver at boot time with /etc/rc.conf: kld_list="radeonkms" (from freebsd.org)

I have the following Kernel: Linux 3.13.0-xx-lowlatency on Ubuntu 14.04 LTS Trusty Thar

My graphics card is in the Evergreen family.

What can I do to get the radeon driver working?

  • Could you update your post to include what Distro you are using? This can help isolate what packages and dependencies are needed to get your graphics driver working. The Official Debian Wiki has a straight forward guide on getting your AMD graphics working but steps will be different even for other Debian derivative Distros. – kemotep Mar 20 '18 at 13:39
1

I managed to get the radeon driver working. It was blacklisted, so I had to disable (rename or remove) the file /etc/modprobe.d/disable-radeon.conf. Additionally, I added radeon to /etc/modules and put options radeon modeset=1 in /etc/modprobe.d/.

Now reboot and check lsmod | grep radeon.

Radeon KMS and DRI2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.