0

I previously installed php56 in aws but i had to update to 7.1. When I do, I couldn't install phpmyadmin anymore. I tried to search on the net but all are said to remove php5.6 then to install 7.1. It kept telling me that the processes conflict with each other. The errors as follows.

--> Finished Dependency Resolution
Error: php56-process conflicts with php-process-5.3.29-1.8.amzn1.x86_64
Error: php70-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
Error: php56-xml conflicts with php-xml-5.3.29-1.8.amzn1.x86_64
Error: php56-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

p.s. I did try to use --skip-broken too but then it skipped installing phpMyAdmin.

Could you show me the correct procedure to install or fix this issue?

I posted this same question at Stack Exchange but them told me to come ask here or Super User.

  • You also seem to have a php 5.3 floating around on there? – Ulrich Schwarz Mar 13 '18 at 6:20
  • @UlrichSchwarz, I removed php and reinstalled. i tried sudo yum remove php* and checked back with sudo yum list installed php* and there's no php left. is there anywhere 'em could remain? – Nerdar Mar 13 '18 at 8:52
  • 1
    Please don't post images of text. Copy and paste the text itself into your question and format it as code by selecting it and pressing Ctrl-K or by using the editor's {} icon. – cas Mar 14 '18 at 4:37
  • okay i replaced the image with the texts. – Nerdar Mar 14 '18 at 4:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.