0

So I'm trying to install Azure on CentOS with yum: link.

But it keeps telling me it needs libpython2.7.so.1.0:

[root@minnow02 Desktop]# yum install azure-cli
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.sfo12.us.leaseweb.net
 * extras: mirror.sfo12.us.leaseweb.net
 * updates: mirror.sfo12.us.leaseweb.net
Resolving Dependencies
--> Running transaction check
---> Package azure-cli.x86_64 0:2.0.28-1.el7 will be installed
--> Processing Dependency: libpython2.7.so.1.0()(64bit) for package: azure-cli-2.0.28-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: azure-cli-2.0.28-1.el7.x86_64 (azure-cli)
           Requires: libpython2.7.so.1.0()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

But I have python 2.7:

[root@minnow02 Desktop]# python -V
 Python 2.7.5

[root@minnow02 Desktop]# find / -iname "*pyth*.so*"
/usr/lib/libpython2.7.so.1.0
/usr/lib/libpython2.7.so
/usr/lib/libpython2.7.so.1.0()(64bit)
/usr/local/python2.7/lib/libpython2.7.so.1.0
/usr/local/python2.7/lib/libpython2.7.so
/usr/local/python2.7/lib/libpython2.7.so.1.0()(64bit)

What's going on?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.