1

When I run gnome-terminal from the command line and hit return, the shell prompt appears immediately when the gnome-terminal window is open, as if gnome-terminal & was executed. This is unlike xterm, which will not return to the shell prompt unless it is started in the background.

My question is how I can start gnome-terminal in the foreground the same way as xterm, such that it won't return to the shell prompt after entering return unless I explicitly run gnome-terminal &?

marked as duplicate by don_crissti, JdeBP, Kiwy, Toby Speight, telcoM Mar 13 '18 at 9:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @don_crissti gnome-terminal --disable-factory works – user2196452 Mar 12 '18 at 19:41