1

I am trying to run an executable on a remote server, to which I connect via ssh -Y. I think the executable uses openGL

The server runs Ubuntu and the local system runs OSX.

ssh -Y normally opens a display on my local machine by X11. This works well with other applications (firefox, matlab etc..)

This time I get the message:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  35
  Current serial number in output stream:  34
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  34
  Current serial number in output stream:  35

I also ran glxinfo (I was trying things I found on forums) and got this

name of display: localhost:11.0
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  23
  Current serial number in output stream:  22

Could someone help with this?

Thank you!

  • What’s your local machine running? – Stephen Kitt Mar 12 '18 at 15:35
  • 2
    Are you using XQuartz? – Stephen Kitt Mar 12 '18 at 15:42
  • Yes, XQuartz 2.7.11 – Adam Gosztolai Mar 12 '18 at 15:50
  • You may need to specify option +extension GLX in your XQuartz command. – mviereck Mar 12 '18 at 16:12
  • 2
    Try the following: 1) ensure you are running up-to-date Xquartz. 2) in a terminal, defaults write org.macosforge.xquartz.X11 enable_iglx -bool true 3) restart xquartz. This worked for me to get a simple java app running. I tried "glxgears" and it starts, but the gears don't turn. I presume they're supposed to. – Dan Pritts Jul 5 '18 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.