• Fresh install of Centos 7
  • KDE
  • kernel: 3.10.0-693.21.1.el7.x86_64

After I do a yum update to update all of the packages, reboot no longer works. I tried to track the problem with no avail. For fun, I tried KDE's Leave > Reboot via the GUI. This worked successfully. I then tried shutdown -h now and that also worked flawlessly. Though, reboot hangs IMMEDIATELY after I hit [Enter], waits about 5-seconds, then goes into Kdump. I get a /var/log/crash/[host]/vmcore-dmesg.txt but have no idea how to interpret the kernel panic's or call traces.

Is there an easier way to find out what's happening and fix what's wrong with my reboot command?

  • To reboot CentOS, you can use /usr/sbin/init 6 – Knud Larsen Mar 11 at 0:02

The canonical way to reboot, is now

systemctl reboot

since populate majority of linux distros

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.