6

I am using KDE Plasma 5.12. In the previous version of Plasma I could show the global menu for an application below the title bar(Settings > Application Style > Widget Style > Fine Tuning > Menubar Style: In application). However in Plasma 5.12 I can only show a button in the title bar and click to have a vertical menu, which is annoying because this is slower than the in application menu bar. How can get the "In Application" menu bar back? An image showing the previous setting: https://i.stack.imgur.com/qTMZb.jpg

EDIT: also I don't want the global menu on a separate panel (like unity)

4

My personal opinion, based on some reverse engineering I've just finished on this subject, is that, with all due respect, KDE developers did a big mess here.

In a fit of oversimplification, the option you mention is no longer available. The global menu is now automatically enabled when you place a global menu applet in a panel or add the menu button to the window decoration in Buttons tab of the Window Decorations module.

Otherwise the global menu should be automatically disabled, and the classic "In Application" Menu Bar used instead.

With some exceptions.

  1. KCalc for example, behaves ad described. Just remove any global menu applet and the application menu button from the window decoration, to get back KCalc "in application" menu.
  2. But other applications, such as Ark, KMenuEdit, Muon, Okteta, KHelpCenter, just to mention a few, when you use the application menu button or the global menu applet at least one time, remain in this state even after you remove the application menu button or the global menu applet, with no access to the menu whatsoever. It seems a bug to me. For such kind of application, you have to manually edit their configuration file (when the application itself is closed, of course). You'll find them in the ~/.config folder. Search by the application name. For Ark, the configuration file is:

    ~/.config/arkrc

There change

MenuBar=Disabled

with

MenuBar=Enabled

This restores "in application" menu (but remember to remove any global menu applet and the application menu button from the window decoration before!)

  1. In addition to the rules above, other applications implement a further mechanism to switch on and off "in app" application menu, using CTRL+M hotkey (given that you have restored the "in application" menu as described in the point 1). For example Dolphin and Gwenview support CTRL+M as described. Kate supports CTRL+M but kindly emits a warning before hiding the menu. Konsole terminal instead, which acts it's too cool for all the other applications, wants CTRL+SHIFT+M to switch the menu on and off. The selected state is persistent after system reboot.

  2. And it's not over. Other plasmoids designed as a replacement of the global application menu, such as "Active Window Control" will disable your "in application" menu, despite any other contrary directive you may have set. So, I suggest you to make your tests in a clean KDE plasma environment.

-1

Add widget called "Global Menu" for your Plasma Panel and remove the button from the title bar. KDE global menu disappeared

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.