0

I have Ubuntu 17.10 on USB Flash drive and in VM VirtualBox.

I have a QNX4 image file on an external hard drive that I can mount on the computer running from the Ubuntu 17.10 USB flash drive.

I have another computer with Ubuntu 17.10 running in VM VirtualBox Version 5.2.2 r119230 (Qt5.6.2) that gives me an error when trying to mount the QNX4.img file. The error I get is

"/mnt/QNX4_Drive: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error."

I have the external hard drive shared from host to virtual machine.

I perform on system running Ubuntu from USB

modprobe qnx4
mount -t qnx4 QNX4.img /mnt/QNX4_Drive -o loop

which works fine and I can access the files.

on Windows 7 pro system running VM VirtualBox running Ubuntu

    modprobe qnx4
    mount -t qnx4 /media/sf_C_DRIVE/QNX4.img /mnt/QNX4_Drive -o loop

Produces the error message listed above

Is there something else I need to do on the VM VirtualBox to be able to mount image files on the host machine?

  • have you simply tried attaching the ISO/IMG as a virtual CD/DVD ? – ivanivan Mar 9 '18 at 16:43
  • Tried to connect using Devices -> Optical Drives -> Choose disk image... VirtualBox - Error Failed to open the disk imiage file Thus this does not work. – Kevin Eisinger Mar 9 '18 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.