0

I have a M-Audio Keystation 61es USB keyboard, and I could not manage to make it work under Linux despite a reasonable amount of trying.

My system is Linux Mint 17.2 (rafaela). My laptop is an Asus Zenbook UX303L.

When the keyboard is plugged in USB, the LED on it shows that it powers up, and it sometimes appear in lsusb, but most of the time it does not even appear there. Does this mean it is a hardware problem, or is there something I can do to fix this ?

When it does appear in lsusb, it does not show up in QjackCtl, and despite trying everything I could find in forums and tutorials for fixing this, I never got past this problem.

The keyboard worked fine under Windows.

Any advice on what can be tried at this point would be greatly appreciated.

  • does anything turn up in the dmesg when you plug or unplug the midi keyboard? – fcbsd Mar 9 '18 at 0:04
  • @fcbsd I'm not sure, what do I have to look for exactly ? The complete output of dmesg is here :codeshare.io/aynDxe – Denis Mar 9 '18 at 0:24
  • you are getting usb usb1-port1: unable to enumerate USB device messages in your dmesg - hence kernel doesn't know which driver to use to communicate with your midi keyboard. – fcbsd Mar 10 '18 at 9:21
  • @fcbsd Indeed this part appears only after branching the keyboard, and stays after it is unplugged. I could not find a linux driver for this keyboard. I updated the kernel but it did not help. Apparently somebody solved this by changing usb cable, I ordered a new one to try this solution. – Denis Mar 12 '18 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.