-1

Background info:

I have 2 physical hard drives, on the primary was Ubuntu and the secondary I had Solus installed. The Ubuntu install was installed with the partition and Home directory encrypted. I decided to try a different version of linux instead of Solus (Ubuntu GamePack, so not exactly different). At the installation prompt I chose, stupidly looking back, 'Erase disk and install Ubuntu' instead of 'Something else' (even those I specifically chose the second hard drive to install to). I think it may have erased my Ubuntu installation that was on the primary partition as there is only one MBR showing up now and on the grub menu there is only one option.

I also cannot access the encrypted partition from within this new Linux install (it doesn't accept my passphrase). I have tried Boot-Repair and after that I also tried os-prober followed by update-grub

If it has done what I suspect it may have:

  1. Is it repairable? (I'm not that familiar with Linux as a whole)

  2. Am I able to recover the information that is held within the LUKS encrypted partition? (this is the most important, as it has data that isn't backed up anywhere else)

Edit: I was not able to resolve the issue of formatting over the primary Linux partition, BUT I was able to access the data from the encrypted LUKS and Home areas. Below is the procedure in case anyone else needs to recover data and has done what I did.

Caveat: You need to know your login password and the password you used to encrypt with LUKS. It is possible to recover the passphrase if you don't remember it (granted that you created one to begin with). I did half of this with GUI and half in the Terminal.

  • Please put your solution (your answer) in as an answer (below) and not in the question. You can then accept your own answer. – roaima Mar 9 '18 at 0:18
0

Open Disks, then click the unlocked padlock icon below the partitions. Use your LUKS password. Once the partition is unlocked you will need to mount it. Navigate to "/home/.ecryptfs/YOURUSERNAME/" (without quotations). Open up a Terminal window and input this command sudo ecryptfs-recover-private followed by “.Private” folder. Follow the prompts and use LOGIN password to unlock the directory. It will tell you where the folder is mounted, it should be in "/tmp/ecryptfs.RANDOMHEXSTRING". You can then navigate there by whatever means you like and get the data you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.