1

I am in Linux Mint 18.3 KDE with Plasma 5.8 LTS.

Can I install 5.12 LTS? How?


Mint 18.3 has already the kubuntu-ppa/backports PPA enabled but this doesn't go above 5.8 in ubuntu-16.04-based systems.

As far as I know the Neon PPA brings the very latest Plasma - I only want the LTS 5.12 but that's the latest as I write - but I cannot add that repository:

~ $ sudo add-apt-repository ppa:project-neon/ppa
[sudo] password for cip: 
'This PPA does not support xenial'
Cannot add PPA: ''This PPA does not support xenial''.

That's odd, as Neon is based on Xenial, just like Mint 18.

The same with kubuntu/beta:

~ $ sudo add-apt-repository ppa:kubuntu-ppa/beta
'This PPA does not support xenial'
Cannot add PPA: ''This PPA does not support xenial''.

What worked was ppa:kubuntu-ppa/staging-plasma, but that has provided only an upgrade from 5.8.8 to Plasma 5.8.9.


Why can Neon use a Xenial base for latest Plasma but other Xenial-based systems cannot? Or can they? and simply there isn't a ppa for that?

How come the Xenial-based Neon PPA says that it doesn't support Xenial?

  • The project-neon PPA is ancient: last built ~440 weeks ago. The kubuntu/beta is too new: it only supports Ubuntu 17.10 and 18.04. There's no evidence either PPA is based on 16.04. – muru Mar 7 '18 at 9:07
  • @muru - present Neon is based on Xenial: neon.kde.org/faq. Is there another ppa for Neon then? – user32012 Mar 7 '18 at 9:31
-2

Try this:

sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get install php7.0 php5.6 php5.6-mysql php-gettext php5.6-mbstring php-xdebug libapache2-mod-php5.6 libapache2-mod-php7.0
sudo a2dismod php7.0 ; sudo a2enmod php5.6 ; sudo service apache2 restart

Source: https://stackoverflow.com/questions/39824219/install-php-5-3-or-5-4-on-ubuntu-16-04-xenial-and-apache

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy