0

I'm a GNU/Linux user and love it, but I have been struggling to correctly install this system on my computer (laptop), all due to the graphic graphics card. Here are the specs of the computer:

Intel Core i7-7700HQ (CPU)
Intel HD Graphics 630 (Integrated)
NVIDIA GeForce GTX 1050 (Dedicated)
Computer: MSI GL72M 7RDX (just in case you want to know)

I've tried several things to make it work and I'll mention them:

First I tried to install Arch and tried to configure xorg (with nouveau and intel and also with nvidia and intel). Whenever I tried to start it, it shuted down.

Then I moved to elementaryOS. In this distro, I couldn't even get to the live USB because it stopped during splash screen. After that, I realized that I had to erase splash from kernel parameters and I had to add the nomodeset parameter. All went well, until I tried to install nvidia proprietary drivers (and blacklist nouveau), because it was draining my battery in less than a hour. When I did that, the screen became black and I couldn't even access another tty. I had to install it back (because I tried to uninstall the driver, but nothing happened after that). Then I tried to install bumblebee in order to use when to use NVIDIA and when to use Intel. The same happened, but when I uninstalled it, everything was just fine. But then, I removed wingpanel to switch to another version of it, but now, the screen is still black, yet I can access another tty. I tried to install it back, but it is still the same.

Before you tag this as duplicate, I have one thing to say. I tried a lot of things used on many situtations similar to mine and NOTHING worked. So, What can I do to have my distro back?

@edit

P.S: Also, when I was on Arch, when I ran xrandr or related commands, the output was always like Cannot find screen.

P.S 2: System is in dual-boot with Windows, on separate disks.

0

I think the biggest thing u need to settle on is what linux distribution you want, because the steps to getting nvidia drivers installed & working is not universal. I am not familiar with arch or elementaryOS. I am very familiar with SLES {which you won't be using} but OpenSuse you could use and over the last ~2 years I have found Suse to be fairly easy regarding nvidia drivers where it can be as simple as

  • download Nvidia...run file, will most likely be x86-64 for you
  • switch user or log in as root on your linux system
  • init 3 or corresponding systemd or sysctl command to go to run level 3
  • execute ./Nvidia..run file
  • say yes to automatically modify xorg.conf file

if the nouveau driver is running by default, that has to be disabled. depending on your linux distribution the Nvidia.run file may or may not be able to do that automatically, and depending on your linux distribution sometimes it's as easy as /etc/modprobe.d/blacklist.conf and adding blacklist nouveau. Or you may need to add a kernel boot parameter saying don't use nouveau, Other times you have to do things like dracut and create a new initramfs

you can read about all that by doing a web search on linux disable nouveau

what can also be a big help when no instructions for doing this seem to work for you, is in your boot parameters where you have splash=silent set that to splash=verbose

  • Already did that, forgot to mention. That was my last try, even blacklisting nouveau, but that didn't seem to work. Thanks anyway – MoonWalker Mar 6 '18 at 18:53
  • years ago, I had failed getting nvidia working in an earlier version than SLES 11.4; sometimes the graphics in linux can be completely broken/bugged depending on the distribution & version; in my opinion linux as a whole is still in the dark ages regarding graphics drivers – ron Mar 6 '18 at 18:57
  • But the problem is: this is the only computer I have this issues. I'm thinking that it is using NVIDIA all the time and it can't access the Intel Graphics card – MoonWalker Mar 6 '18 at 19:00
  • maybe try specifying in the bios to explicitly use pci-express graphics card and disable onboard; and make sure you are not running and old bios version; i am not surprised you are having problems since it's a newer laptop if it's not nearly as new a linux distro then linux is probably not recognizing various hardware, chipsets, etc. would be my guess – ron Mar 6 '18 at 21:42
  • and especially efi vs legacy bios and all that; try setting everything to legacy in the bios, don't set anything to "uefi only". – ron Mar 6 '18 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.