5

When I run the apt-get upgrade command I get this error:

Reading package lists... Done
Building dependency tree        
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libvlc5 : Depends: libvlccore9 (>= 4.0.0~rc1~~git20180305+r74659+127~ubuntu16.04.1) but it is not installed
vlc : Depends: vlc-bin (= 4.0.0~rc1~~git20180210+r74136+127~ubuntu16.04.1) but it is not installed
   Depends: vlc-plugin-base (= 4.0.0~rc1~~git20180210+r74136+127~ubuntu16.04.1) but it is not installed
   Depends: vlc-plugin-qt (= 4.0.0~rc1~~git20180210+r74136+127~ubuntu16.04.1) but it is not installed
   Depends: vlc-plugin-video-output (= 4.0.0~rc1~~git20180210+r74136+127~ubuntu16.04.1) but it is not installed
E: Unmet dependencies. Try using -f.

I already tried apt-get install -f. This is the output:

(Reading database ... 568381 files and directories currently installed.)
Preparing to unpack .../libvlccore9_4.0.0~rc1~~git20180305+r74659+127~ubuntu16.04.1_amd64.deb ...
Unpacking libvlccore9:amd64 (4.0.0~rc1~~git20180305+r74659+127~ubuntu16.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/libvlccore9_4.0.0~rc1~~git20180305+r74659+127~ubuntu16.04.1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/x86_64-linux-gnu/libvlccore.so.9.0.0', which is also in package libvlccore8:amd64 3.0.0~~git20171210+r73147+99~ubuntu16.04.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Errors were encountered while processing: /var/cache/apt/archives/libvlccore9_4.0.0~rc1~~git20180305+r74659+127~ubuntu16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • Did you add new recent repos? If it's true, maybe recent repos isn't compatible with your distro. Did you try 'apt-get update && apt-get upgrade' before trying to install new package? – Yurij Goncharuk Mar 5 '18 at 20:29
  • Sorry for my comment, I omit 'apt-get upgrade' phrase. Please try 'apt-get clean' and 'apt-get update' again. Maybe old cache is preventing correct update. – Yurij Goncharuk Mar 5 '18 at 20:51
8

You’re using the VLC daily master branch build PPA, which explicitly states

CAUTION: The builds in this archive are fully automated, and do not go through any quality assurance whatsoever. Build breaks and functional regressions occur frequently.

DO NOT USE this archive if you are not prepared to cope with such problems.

It appears you shouldn’t be using this archive.

You should remove it from your repositories, run apt update, uninstall vlc and all related packages, then re-install them (which will install the version available from whatever other repositories you have configured).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.