0

According to the man page:

MKNTFS(8)
...

mkntfs is used to create an NTFS file system on a device (usually a disk partition) or file.

The problem is that when I give it a pre-created 64GB file as an argument it wants a device:

] mkntfs share1.dat # share1.dat is a pre-created 64 GB file

share1.dat is not a block device.
Refusing to make a filesystem here!

How do I get it to accept the share1.dat file as a file and create an NTFS filesystem on this file that I can later mount and share?

1

You need to force it with the -F option:

mkntfs -F share1.dat

This also disables safety checks for mounted volumes, so take care...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.