1

I have a Lenovo Thinkpad X220. I recently changed my hard disk drive to an SSD and installed Arch Linux on it.

What happens is that, when I try to connect to a Wifi Network via wifi-menu, it doesn't connect. wifi-menu shows me the different networks that are available to connect, and when typing the password it immediately fails.

Not sure what drivers I should install, and the only way I can connect to the Internet is through a wired connection.

I think this can be useful:

> $ lspci -nnk | grep -iA2 net

00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit 
Network Connection (Lewisville) [8086:1502] (rev 04)
Subsystem: Lenovo ThinkPad T520 [17aa:21ce]
Kernel driver in use: e1000e
--
03:00.0 Network controller [0280]: Intel Corporation Centrino 
Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
Subsystem: Intel Corporation Centrino Advanced-N 6205 (802.11a/b/g/n) 
[8086:1311]
Kernel driver in use: iwlwifi

So this is the output for when trying to connect manually using wpa_supplicant

> $ sudo wpa_supplicant -c /etc/wpa_supplicant.conf -i wlp3s0  
Successfully initialized wpa_supplicant
wlp3s0: SME: Trying to authenticate with 82:2a:a8:31:9c:51 (SSID='CATEGORIES' freq=2437 MHz)
wlp3s0: Trying to associate with 82:2a:a8:31:9c:51 (SSID='CATEGORIES' freq=2437 MHz)
wlp3s0: Associated with 82:2a:a8:31:9c:51
wlp3s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
wlp3s0: CTRL-EVENT-DISCONNECTED bssid=82:2a:a8:31:9c:51 reason=3 locally_generated=1
wlp3s0: SME: Trying to authenticate with 82:2a:a8:31:9c:36 (SSID='CATEGORIES' freq=2412 MHz)
wlp3s0: SME: Trying to authenticate with 82:2a:a8:31:9c:51 (SSID='CATEGORIES' freq=2437 MHz)
wlp3s0: Trying to associate with 82:2a:a8:31:9c:51 (SSID='CATEGORIES' freq=2437 MHz)
wlp3s0: Associated with 82:2a:a8:31:9c:51
wlp3s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
wlp3s0: WPA: Failed to set PTK to the driver (alg=3 keylen=16 bssid=82:2a:a8:31:9c:51)
wlp3s0: CTRL-EVENT-DISCONNECTED bssid=82:2a:a8:31:9c:51 reason=1 locally_generated=1
wlp3s0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
wlp3s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="CATEGORIES" auth_failures=1 duration=10 reason=CONN_FAILED
^Cnl80211: deinit ifname=wlp3s0 disabled_11b_rates=0
wlp3s0: CTRL-EVENT-TERMINATING 
2
  • Connect manually: it will provide more detailed debugging information. – jasonwryan Mar 5 '18 at 15:09
  • How did you create the conf file? What commands did you use? Can you post the conf (with the passphrase redacted)? – jasonwryan Mar 6 '18 at 20:13
0

Try to check the state of your wifi interface with ip link. If it is down, you can bring it up with sudo ip link set dev [your interface name] up.

As jasonwryan stated, connecting manually (you can use wpa_supplicant) might give you more information on the problem.

5
  • When using wpa_supplicant I'm seeing authentication problems but I'm totally sure I'm using the right key for the right ESSID. – sant016 Mar 5 '18 at 16:44
  • Did you form a config file with wpa_passphrase? – corsel Mar 5 '18 at 16:52
  • Yes, and the information put there is correct. – sant016 Mar 5 '18 at 16:57
  • 1
    @sant016 "authentication problems" is not a helpful description, nor an error message. Edit your question with full output. – jasonwryan Mar 5 '18 at 17:14
  • @jasonwryan now edited. Sorry. – sant016 Mar 6 '18 at 15:40
0

In the begining I have the same Problem with WiFi-Menu, then I mannualy connect with the internet like this:

  1. Discover what is your interface with the follow command: iwconfig

    Normally, your wifi interface is like this construct: wlp2s0. I'll put <interface name> where you need to put your interface

  2. Put the interface up:

    ip link set <interface name> up
    
  3. Scan your interface to see if it is enabled:

    iwlist <interface name> scan | less
    
  4. If it is in the list, down the interface:

    ip link set interface down
    
  5. Go the netctl examples Directory:

    cd /etc/netctl/examples
    
  6. Copy the wireless-wpa to netctl Directory with the name you want:

    cp /etc/netctl/examples/wireless-wpa /etc/netctl/wifi_name
    
  7. Open the wireless-wpa file to edit with your preferred editor (e.g. nano):

    sudo nano /etc/netctl/wifi_name
    
  8. Change the following settings:

    Interface: <Interface name>
    ESSID: <your internet name>
    key: <your internet password>
    

    Save and exit

  9. Run the netctl with the following commands:

    cd /etc/netctl
    netctl start wifi_name
    
  10. If an error message appears, try this commad:

    ip link set dev <interface name> down
    
  11. try run your internet connectivity:

    ping -c 3 www.google.com
    
  12. If working, enable your internet to run permanently:

    netctl enable wifi_name
    
-1

Try installing the NetworkManager package using chroot in the install media and use nmtui.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.