0

The firefox fullscreen animation is too slow for me. I have a relatively small screen, so I want a quick way to fill my screen with content. How do I make the animation faster?

Version: firefox-58.0.2-1.fc27.x86_64 (Fedora Linux 27)

Additional clues

I have two separate user accounts. One of them is fine, but the other is too slow.

In one of the user accounts, I have notes suggesting that I set browser.fullscreen.animateUp as mentioned by this article. However, this setting can no longer be found in about:config.

In both user accounts, I use GNOME and have enabled the Impatience extension to GNOME, set to 0.66 of the default delay. I have notes suggesting that this was also a very useful step to help with Firefox fullscreen animation specifically. I can see no other settings in Impatience. Setting the delay to zero does not fix my problem.

0

In recent versions of Firefox, you want to set the preference toolkit.cosmeticAnimations.enabled.


Found by searching for anim in about:config. (And also, in the good profile I clicked on the "Status" column to sort it so all the "modified" preferences were together, so I could see that this particular "anim" preference was one that I had changed).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.