0

I am trying to create a bootable USB using the hybrid iso image of debian from https://cdimage.debian.org/images/unofficial/non-free/images-including-firmware/9.3.0-live+nonfree/amd64/iso-hybrid/

The command I used on my empty flash drive at /dev/sdb is:

sudo dd if=debian.iso of=/dev/sdb bs=4M
sync

Source: https://www.debian.org/CD/faq/#write-usb

But the resulting USB is not detected during booting and not shown in the bootable devices list. I also verified using gparted that the bootable flag is already set.

As an alternate, I switched to a windows PC and downloaded the utility RUFUS from https://rufus.akeo.ie/ and this worked like a charm and is able to boot correctly.

I obviously hate to switch to a windows machine everytime I need to create a live usb.

Can someone please verify where my mistake is with the dd command procedure?

  • 1
    Did you make sure your USB stick was UNMOUNTED first? bs=4M sysnc is used on Macs. Try: sudo dd bs=4M if=input.iso of=/dev/sd<?> conv=fdatasync . Presumably you changed "user" you your own username – user8779 Mar 5 '18 at 10:57
  • I have never created a bootable medium on linux with dd. It might be possible, however i dont know how. If you have a graphical user environment in your linux machine i can recommend the ubuntu package usb-creator-gtk. It always reliably did the job for me. That package is probably also available on debian if thats the distro your using. – UXELDUXEL Mar 5 '18 at 12:47
  • I would also check the checksums (md5, sha256,...) of the ISO file. – Alex338207 Mar 5 '18 at 14:15
  • @Alex338207 md5sum was thoroughly checked. – Loves Probability Mar 5 '18 at 14:33
  • 1
    Have you tried installing Etcher on Linux instead? maketecheasier.com/linux-live-disks-etcher – user8779 Mar 5 '18 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.