6

I'm trying Linux Mint Debian Edition XFCE, and want to use a specific theme; only drawback - the font color and font shadow are unreadable, how can I change them? Also the active/inactive color window separation is very hard to distinguish. I added a screenshot for demonstration. enter image description here (seems that stackexchange doesn't zooms in the image when clicking, so you have to use the "right-click>view image" option, I apologize)

2 Answers 2

3

For others with the same problem. Go to window manager and select the same theme that you selected in Appearance. This way the style of the window title would match the overall color scheme.

3
  • 1
    You're a saver!
    – msangel
    Nov 28, 2018 at 14:24
  • That was not the most intuitive solution :P
    – Jaakko
    Apr 23, 2019 at 11:10
  • Also, not all themes have a matching one in window manager. E.g. I use Dust Sand and don't see it.
    – toolforger
    Oct 29, 2019 at 7:39
1

You will need to copy the theme from "/usr/share/themes/themename/gtkrc" to $HOME/.config/gtk-2.0/gtkrc and modify it. Please see xfwm4 theme guide on the xfce wiki.

(1) Shadow,

Text shadow

A shadow can be added to the title text by setting the boolean value “title_shadow_active” for the focused window, and “title_shadow_inactive” for the other unfocused windows.

Possible values are “false”, “true”, and “frame”.

(2) Titelbar decorations,

For title bar decorations, xfwm4 uses 5 pixmaps named title-1-active.xpm to title-5-active.xpm with top-left-active.xpm and top-right-active.xpm making up the corners on each end as per figure 2 below.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.