2

I have just installed the 'vagrant-vmware-fusion' 5.0.4 official plug-in from HashiCorp, in Vagrant.

I am using Vagrant with VMWare Fusion 10 running in High Sierra.

However, when doing the vagrant up for a VM, I am having an error.

As advised in the error message, I have done a reboot, however the error is still happening.

What to do?

$ vagrant up --provider vmware_fusion
Bringing machine 'default' up with 'vmware_fusion' provider...
==> default: Box 'hashicorp/precise64' could not be found. Attempting to find and install...
    default: Box Provider: vmware_desktop, vmware_fusion, vmware_workstation
    default: Box Version: >= 0
==> default: Loading metadata for box 'hashicorp/precise64'
    default: URL: https://vagrantcloud.com/hashicorp/precise64
==> default: Adding box 'hashicorp/precise64' (v1.1.0) for provider: vmware_fusion
    default: Downloading: https://vagrantcloud.com/hashicorp/boxes/precise64/versions/1.1.0/providers/vmware_fusion.box
==> default: Successfully added box 'hashicorp/precise64' (v1.1.0) for 'vmware_fusion'!
==> default: Cloning VMware VM: 'hashicorp/precise64'. This can take some time...
==> default: Checking if box 'hashicorp/precise64' is up to date...
==> default: Verifying vmnet devices are healthy...
The VMware "vmnet" devices are failing to start. The most common
reason for this is collisions with existing network services. For
example, if a hostonly network space collides with another hostonly
network (such as with VirtualBox), it will fail to start. Likewise,
if forwarded ports collide with other listening ports, it will
fail to start.

Vagrant does its best to fix these issues, but in some cases it
cannot determine the root cause of these failures.

Please verify you have no other colliding network services running.
As a last resort, restarting your computer often fixes this issue.

4 Answers 4

5

After rebooting a couple of times, I decided to try my luck launching "VMware Fusion" before invoking the vagrant up command.

It indeed works; vagrant up does not start VMWare fusion, and so, you have to be running it for vagrant up to be able to deploy a VM.

Ultimately, the error message could be more elucidative.

2
  • Note vagrant up typically dose start the virtual machine by itself. We've been doing this for years over ssh, with no user logged in, no one to launch any app. From time to time, we have had to reboot or re-make the vagrant network file to get it to work. Apr 5, 2018 at 18:39
  • @ChristopherIanStern It is definitively not doing it here with High-Sierra+VmWare Fusion+the paid plug-in from HashiCorp. What virtualisation technology are you using? Apr 5, 2018 at 18:43
2

For me, on OSX Catalina (on a 2018 mac-mini), it was an entirely different solution:

The problem went away after going to System Preferences -> Security & Privacy -> Full Disk Access, and checking the box for VMWare Fusion.

After doing this vagrant up worked smoothly. For completeness, this all happened on Vagrant VMWare Utility v1.0.18 w/ VMware Fusion 12.1.0 Pro.

Curiously, on a different Mac (also Catalina but a 2017 Macbook Pro), I did not have to do this, and I never encountered this problem.

1
  • Nobody upvoted this, but it worked for me on macOS 11.6 Big Sur. No need to reboot or start VMWare. 👍
    – Manu
    Oct 10, 2021 at 12:36
1

Installing the latest Vagrant VMWare Utilities fixes this issue. It is no longer necessary to launch the VMWare Fusion process manually. Not sure why this is not included by default, caused alot of issues when attempting automation.

View the docs

Download a prebuilt system package

1
  • They were the last at the time of my writing. As soon as can get to my Mac, will try again, thanks, Jul 20, 2018 at 18:58
1

I encountered this error message. I had another paused VMware fusion VM running. I shut down that paused VM, executed 'vagrant up' again. vagrant session went past the error message.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .