2

I cannot run emerge-webrsync because it says that snapshots are not found.

Nor can I execute mirrorselect, since I get command not found.

Finally, I tried to run:

$ emerge --ask app-portage/mirrorselect

but this returns the following error:

!!! Repository 'x-portage' is missing masters attribute in '/usr/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility


!!! /etc/portage/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


!!! Your current profile is invalid. If you have just changed your profile
!!! configuration, you should revert back to the previous configuration.
!!! Allowed actions are limited to --help, --info, --search, --sync, and
!!! --version.
  • 1
    What step of the handbook are you at? Are you trying to do these commands inside or outside of the chroot environment? – ErikF Mar 2 '18 at 14:59
  • I am doing inside chroot.Outside everything works. I am trying to do eselect profile list and getting error Failed to get a list of valid profiles exiting – user9385563 Mar 2 '18 at 15:16
  • I'm on the step right after chrooting – user9385563 Mar 2 '18 at 15:16
  • also my /usr/portage dir is empty – user9385563 Mar 2 '18 at 15:25
  • it's solved. All I had to do was run emerge --sync and wait – user9385563 Mar 2 '18 at 15:47
0

You can try to use eselect profile list and then select the right profile with eselect profile set ... command. The gentoo handbook suggest to use the same profile as the tarbal / livecd you used to install gentoo on your hdd. Then you should be able to use emerge --sync and emerge -DuNa world to update your system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.