1

I got a problem when I want to install Fedora 27 from iso file with grub2.

With several terrible hours searching the answer:

  1. Format a USBFLashDrive into fat32.
  2. Install grub2 to USBFlashDrive. In fedora/centos/redhat:

    #mount /dev/sdXY /mnt
    #mkdir /mnt/boot
    for efi#grub2-install --efi-directory=/mnt --boot-directory=/mnt/boot --removable /dev/sdX
    forbios#grub2-install --boot-directory=/mnt/boot /dev/sdX
    
  3. Write the boot entries in grub.cfg. So boring cause of many many be called correct. After tried at least 20 times, got the solution here:

    menuentry 'Fedora-Workstation-netinst-x86_64-27-1.6' {
        set isofile='/boot/iso/Fedora-Workstation-netinst-x86_64-27-1.6.iso'
        loopback loop $isofile
        linux (loop)/isolinux/vmlinuz inst.stage2=hd:LABEL=Fedora-WS-dvd-x86_64-27 iso-scan/filename=$isofile quiet
        initrd (loop)/isolinux/initrd.img
    }
    

Reference

After got the correct reference, I was more confused thought problem was passed. Can anyone point it out what part in iso file makes the boot entry in grub.cfg different? Specially what's the difference of Stock installation medium and Workstation live medium of Fedora.

0

Had the same problem. Here is updated entry with boot option from "EFI/BOOT/grub.cfg" in iso. [use grub2-mkconfig to update grub.cfg with custom entry]

I put iso in root folder and here is what worked for me.

menuentry 'Fedora-Workstation-Live-x86_64-27-1.6' {
    loopback loop (hd0,msdos1)/Fedora-Workstation-Live-x86_64-27-1.6.iso
    linux (loop)/isolinux/vmlinuz iso-scan/filename="/Fedora-Workstation-Live-x86_64-27-1.6.iso" root=live:CDLABEL=Fedora-WS-Live-27-1-6 rd.live.image quiet
    initrd (loop)/isolinux/initrd.img
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.