0

Search engine turns up loads of reports of this error message when installing guest additions to an application. I read about 50 of them, and tried some, but none of them made any difference. Here's what I have:

  • I had a virtual machine created with Slackware current (about a year ago. kernel was 4.3.90)
  • The screen didn't maximize, so I realized I had to install Guest Additions to get that working.
  • Mounted the Guest additions and tried to execute /run/media/.../VBoxLinuxAdditions.run. It started executing fine but stopped at the error Failed to set up vboxadd. It points to a log file, which points to another log file - neither with any useful information.

I have the compilers installed, kernel headers installed, dkms compiled (and installed, though I later read that VBox 5.* doesn't need that anymore?). I can't seem to tease more information (logs etc) from the procedure.

Virtualbox is 5.1.22, kernel 4.3.90, slackware is Slackware-current (about a year ago). gcc is 4.7.1.

Any suggestions/ideas/debugging I could try?

| improve this question | | | | |
0

There are a few pointers that I can give:

  • the guest additions must be the same version as the virtual-box
  • I needed to make sure that the kernel version is the same as the version of the kernel sources on the system
| improve this answer | | | | |
  • Hallo Ljm. Thanks for the suggestions. I had checked for those things - this is not my first battle ;) At least those are not the cause. – jcoppens Mar 8 '18 at 4:32
0

First, to my understanding of your question "Virtualbox on Slackware: Failed to set up vboxadd", Slackware is your host OS, and I assume that you know VirtualBox Guest Addition should be installed on the guest OS. And what is the guest OS of your Virtalbox VM? If you mean Slackware is the guest OS by "Virtualbox on Slackware", and all got necessary prerequirements like gcc, kernel-header ready, then did you excute the VBoxLinuxAdditions.run with root or a user with sudo privilege? It should be installed with such privileged user. Or, if the version is not so important to you, try to upgrade your Slackware.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.