6

I have Samsung NP360E5A-A07PL laptop with ELAN Smart-Pad (ETPS/2 Elantech Touchpad, according to gpointing-device-settings), and a Logitech M195 wireless mouse (with an USB receiver). On Linux (LUbuntu 12.04 LTS) the wireless mouse stops working from time to time (quite frequently, perhaps every few minutes) for maybe one second.

Disabling touchpad (via gpointing-device-setting) didn't help. Switching to wired USB mouse didn't help either, and it even made situation worse; with wired mouse to make it start working again after freeze I had to re-plug the USB, while with wireless mouse I only have to move it.

The very same hardware setup works without any problems on MS Windows 7 (dual-boot).


Below there is result of running xinput:

jnareb@llaptok:~$ xinput 
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=10   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=11   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ WebCam SC-0311139N                        id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

It looks like the problem occur only after resuming from sleep, and beside mouse freezing I get intermittent short beeps, like on keyboard error, for no discernible reason. It might be that it denotes event that causes mouse freezing.

I don't know where to start looking...

  • there is a feature, in many desktop and distributions, that disable your touchpad when you are typing with the keyboard, try to review your settings about your mouse/touchpad in the settings panel. – user827992 Jul 10 '12 at 14:47
  • there is no problem with touchpad, only with mouse – Jakub Narębski Jul 10 '12 at 15:47
  • most of the times the settings are the same in my experience. – user827992 Jul 10 '12 at 16:22
  • @user827992: First, I can't find such setting in LXDE settings panels. Second, mouse hangs even when I am not typing for a longer time (mouse-only work, no keyboard). – Jakub Narębski Jul 10 '12 at 16:54
  • I have turned off autosuspend for Logitech USB Receivier via powertop. Let's see if it helps (it certainly looks like it, for now). – Jakub Narębski Aug 3 '12 at 13:39
1

For me, it was that I enabled laptop mode, and the mouse would get turned off every few seconds of not using it!

# set laptop mode to 0 in this file:
/etc/laptop-mode/laptop-mode.conf 

sudo service laptop-mode reload
5

This might be problem with too aggressive power-management autosuspend for USB receiver for wireless mouse. One symptom that this is the case is that the problem with mouse "freezing" / "hanging" for a while happens only if laptop works from battery (off AC adapter).

You can turn off autosuspend using powertop text-mode command line tool (run as root, e.g. using sudo).

Go to "Tunables" tab (using right and left arrows), select "Autosuspend for USB device USB Receiver (Logitech)" (using down and top arrows), and turn it off from "Good" to "Bad" (using key).

Unfortunately I don't know how to configure those power settings in persistent way...


I have updated to Ubuntu 12.10 (from 12.04), and I no longer have those problems. Though powertop2 is now useless: it doesn't show power consumption in Watts after upgrade...

  • 3
    To do this permanently, edit /etc/laptop-mode/conf.d/usb-autosuspend.conf and add the id for your mouse device (which you find with lsusb) to AUTOSUSPEND_USBID_BLACKLIST. It should be enough to then restart laptop-mode, but it didn't work for me until i rebooted, for some reason. – Christoffer Hammarström May 5 '13 at 11:34
  • 1
    It worked for me without rebooting, by: 1) restarting laptop-mode (no effect at this step) 2) unplugging and plugging back the mouse – L. Levrel Jun 3 '16 at 19:46
1

Try disabling USB Auto-Suspend:

sudo apt-get install powernap
sudo powernap-action --disable usb_autosuspend

Source: https://askubuntu.com/a/266908/24155

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.