4

In my CentOS 7 laptop while switching from root to user using su user as root, it's asking for user's password.

-bash-4.2# su user
 Password: 

While switching from root to other account it's not supposed to ask for password.

I've tried the same in Fedora 27 and another CentOS 7 machine. There su user as root simply switching the user without asking for user's password.

I'm using the repository provided version of su only.

Any help regarding why this is happening will be helpful.

Updates

Contents of /etc/pam.d/su is as follows

#%PAM-1.0
auth            sufficient  pam_rootok.so
# Uncomment the following line to implicitly trust users in the "wheel" group.
#auth           sufficient      pam_wheel.so trust use_uid
# Uncomment the following line to require a user to be in the "wheel" group.
#auth           required        pam_wheel.so use_uid
auth            substack        system-auth
auth            include         postlogin
account         sufficient  pam_succeed_if.so uid = 0 use_uid quiet
account         include         system-auth
password        include         system-auth
session         include         system-auth
session         include         postlogin
session         optional        pam_xauth.so
  • does it matter which user you switch to? Do you have something unusual in /etc/pam.d/su? – ilkkachu Feb 28 '18 at 20:31
  • And when you first switch to root you use what command(or you make login on a new tty)? Remember that sudo -s and sudo -i as an example create root sessions with and without shell – user34720 Feb 28 '18 at 20:37
  • @ilkkachu It doesn't matter what user I'm switching to. Even su nobody asking for nobody's password which neither has a shell access nor a password..!! I've updated the question with /etc/pam.d/su file. – Abhik Bose Feb 28 '18 at 21:03
  • @nwildner I'm changing to root using su - only. I've tried with sudo -s also but the problem is persistent. – Abhik Bose Feb 28 '18 at 21:04
  • A silly question: Is root's id 0? – Karel Vlk Mar 1 '18 at 15:28
0

The problem was solved after an regular update using yum update. Still it'll be very helpful if I get some insight regarding what may cause this.

Not the answer you're looking for? Browse other questions tagged or ask your own question.