0

My fresh installation of Ubuntu seems to be having an issue detecting eth0. I have tried few things but nothing worked for me.

For example, I have tried what is being advised on this link. Ubuntu eth0 not detected

Furthermore, I added these few lines to /etc/network/interfaces which was originally empty.

auto eth0
iface eth0 inet dhcp

I also tried the following. After downloading the driver from here: https://downloadcenter.intel.com/download/15817/Intel-Network-Adapter-Driver-for-PCI-E-Gigabit-Network-Connections-under-Linux-?product=71307

Entering the following commands:

cd e1000e-3.3.5.3/src

Editing nvm.c, function e1000e_validate_nvm_checksum_generic (line 563) to

s32 e1000e_validate_nvm_checksum_generic(struct e1000_hw *hw)
{
    /*
    s32 ret_val;
    u16 checksum = 0;
u16 i, nvm_data;


for (i = 0; i < (NVM_CHECKSUM_REG + 1); i++) {
    ret_val = e1000_read_nvm(hw, i, 1, &nvm_data);
    if (ret_val) {
        e_dbg("NVM Read Error\n");
        return ret_val;
    }
    checksum += nvm_data;
}


if (checksum != (u16)NVM_SUM) {
    e_dbg("NVM Checksum Invalid\n");
    return -E1000_ERR_NVM;
}
*/


    return 0;
}

Finally, build and install:

make
sudo rmmod e1000e
sudo make install
sudo modprobe e1000e

Upon entering the command ifconfig, I receive the following

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:560 errors:0 dropped:0 overruns:0 frame:0
          TX packets:560 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:54167 (54.1 KB)  TX bytes:54167 (54.1 KB)

wlp3s0    Link encap:Ethernet  HWaddr a4:34:d9:92:f1:58  
          inet addr:192.168.1.82  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: 2602:306:3a54:4190:b664:4bd6:984d:dd39/64 Scope:Global
          inet6 addr: fe80::f960:171e:a497:f047/64 Scope:Link
          inet6 addr: 2602:306:3a54:4190:cba:bd01:e6fd:411c/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2141 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1230 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 

Upon entering the command inxi -SNxz, I receive the following:

System:    Host: abdu-Default-string Kernel: 4.13.0-36-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Unity 7.4.0 (Gtk 3.18.9) Distro: Ubuntu 16.04 xenial
Network:   Card-1: Intel Ethernet Connection (2) I219-V bus-ID: 00:1f.6
           Card-2: Intel Wireless 8260 driver: iwlwifi bus-ID: 03:00.0

So the card is being detected but cannot be used for some reason.

The output for ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether a4:34:d9:92:f1:58 brd ff:ff:ff:ff:ff:ff

Problem solved by following the instruction on this link: https://superuser.com/questions/1104537/how-to-repair-the-checksum-of-the-non-volatile-memory-nvm-of-intel-ethernet-co/1106641#1106641

Any help is appreciated.

12
  • 2
    "I have tried few things" - what things have you tried? Please edit your question to tell us. Feb 28, 2018 at 11:41
  • 1
    Perhaps this is a "eth0 got renamed" question?
    – Jeff Schaller
    Feb 28, 2018 at 11:42
  • @JeffSchaller it might be, but Google suggests wlp3s0 type interfaces seem to be wireless rather than wired. Feb 28, 2018 at 11:42
  • 1
    @AbdullahAlhag Don't put new information in comments. Edit your question instead.
    – Kusalananda
    Feb 28, 2018 at 11:44
  • 1
    @AbdullahAlhag Please, don't put new information in comments. Edit your question instead.
    – Kusalananda
    Feb 28, 2018 at 12:18

0

Browse other questions tagged .