0

I am using Debian Stretch with lightdm. Suddenly, I am no longer asked for a password when I log in. As soon as I fill in my username and press tab, the password field is removed and I can log in without ever entering it.

Moreover:

  • With a command line login, the situation is the same: I only have to enter my username to log in.
  • No password is asked when I use sudo, even across reboots and after executing sudo -K.
  • Some applications, such as the root terminal in Thunar, warn me that due to my 'authentication mechanism setup', I do not need to enter a password.
  • My password is no longer accepted by programs which have a graphic prompt for a password, such as synaptic-pkexec. sudo synaptic-pkexec does work.

The answers I'm finding are specific to settings in lightdm, or in /etc/sudoers. However those files look normal, and this problem seems to be more general. Can anyone offer pointers on how to find out what has changed in my system?

closed as off-topic by Jeff Schaller, G-Man, DarkHeart, roaima, Archemar Mar 5 '18 at 10:04

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, G-Man, DarkHeart, roaima, Archemar
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What did you change? Password authentication does not disable itself for no reason. – Kusalananda Feb 28 '18 at 9:54
  • Any messages from pam* in the journal? Check with sudo journalctl -b to see messages for current boot session. – Mioriin Feb 28 '18 at 10:08
  • I don't remember changing anything, this is why I was puzzled. The journal reports however: lightdm[1193]: gkr-pam: no password is available for user Apparently I have no password set anymore, then. I don't know how this happened. Setting a new password solved everything. Thanks for your help, I'll submit my own answer. – mpjdem Feb 28 '18 at 10:49
2

The root cause was that there was no password set anymore for my user. I executed:

sudo journalctl -b | grep pam

And noticed:

lightdm[1193]: gkr-pam: no password is available for user

The problem was then solved by executing passwd at the terminal and setting a new password.

Not the answer you're looking for? Browse other questions tagged or ask your own question.