0

I have two computer both with a fresh quasi-identical Slackware install. I use Waterfox 56 for browser and try to access my websites on my local webserver. The local webserver uses TLS certificates from my own CA that are correctly imported into the two browsers.

One of my computer cannot load the local websites correctly and hangs at "Performing a TLS handshake". I try clearing the cache and rebooting, nothing worked.

I just tried with another browser (lynx) and got a similar result.

What could be the cause of my browser hanging at the TLS handshake?


I have news: After rebooting my laptop, it can no longer load the websites, like my other computer. But I may have found something: When I try connecting with openssl, like so:

openssl s_client -connect <server_ip>:443

I get CONNECTED(00000003) and then nothing...

Also ssh sessions on the server freeze sometimes, so maybe it is a problem with the server after all.

  • Sorry English is not my primary language. What do not you understand? – madjack Feb 27 '18 at 13:51
  • The problem is not the server because I can load the page from other devices. It is not because of my TLS certificates because the server has other website that use Let's Encrypt certificates and the computer cannot access them either. What else could it be, I really have no idea? – madjack Feb 27 '18 at 14:16
  • I would like to answer my question please – madjack Mar 2 '18 at 11:35
  • Two people voted (including me), but we need more votes to reopen it. You may flag it for moderator intervention, no idea if it works. You will atract more reopen votes reworking a bit the question, too, I think. – Rui F Ribeiro Mar 2 '18 at 11:40
  • @DBLouis the question has been reopened. Thanks for taking the time to post an answer! – terdon Mar 4 '18 at 13:51
1

The cause was very tricky to find. The DHCP client daemon was not applying the MTU setting received from my DHCP server (On my private network I have set the MTU to 9000).

There was a disabled option in /etc/dhcpcd.conf:

option interface_mtu

I enabled it and it worked.

Now I understand why only the local websites could not be loaded, because the server responded with frames that were too big whereas those from the router never exceeded 1500B because they came from my ISP network.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.