1

since I got my Floppy Drive to be found by the system, I trouble with mounting it!

Some specs:

  • Ubuntu Server 16.04 LTS,
  • EIDE-Connected FDD,
  • installed packages for this subject: udisk2and fdutils

I also got the assumed entries in fstab 80-udisks2.rules , the floppy module is loaded and I also can format the disk via fdformat, but I cannot read it. Tried everything with root and as user in group "floppy"

Some results of commands I tried:

  • root@derinity:~# fdmount fdmount (/dev/fd0): Can't access /fd0: No such file or directory
  • root@derinity:~# udisksctl mount -p /dev/fd0 (udisksctl mount:1334): GLib-GIO-CRITICAL **: g_dbus_object_manager_get_object: assertion 'g_variant_is_object_path ( Error looking up object with path /dev/fd0
  • root@derinity:~# fdmount -l NAME TYPE STATUS fd0 1440K not mounted
  • root@derinity:~# fdformat /dev/fd0 Double-sided, 80 tracks, 18 sec/track. Total capacity 1440 kB. Formatting ... done1 Verifying ... Read: : Input/output error Problem reading track/head 0/0, expected 9216, read -1 [ADDED]

Hopefully,

dor_sax

  • Are there any /dev/fd* entries? – Ignacio Vazquez-Abrams Feb 26 '18 at 18:21
  • Yes, /dev/fd0 – dor_ sax Feb 26 '18 at 18:28
  • You say you can format it, have you done so? Have you created a filesystem on the disk that can be mounted? – terdon Feb 26 '18 at 18:39
  • I added the Output of fdformat right now. I assume I din`t create a FileSystem? – dor_ sax Feb 26 '18 at 18:40
3

(This is from memory — I haven't had a floppy drive in nearly two decades.)

After formatting a floppy, it doesn't have a filesystem on it — so you need to create one before mounting it. E.g., to put a FAT filesystem on it, you'd do mkfs.vfat /dev/fd0 (plus any options for label, etc.) Or you could put ext2 on it with mkfs.ext2 /dev/fd0; ext3/4 is likely not possible because the journal is much larger than a floppy.

Then it ought to mount normally, e.g., with mount /dev/fd0 /media/floppy

2

Another option is to use superformat, which will format the floppy and create a DOS file system with the appropriate parameters (using mtoolsmformat); for example,

superformat /dev/fd0 hd

to format a 1440K disk.

However even fdformat should be able to verify your formatted floppy without problem, so there’s something else wrong somewhere...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.