1

I am very new to Linux, running an HPC via ssh. I was running a shell script within a screen, and a process was taking too long so I killed it via htop activity. When I reattach the screen that was running the script, it is unresponsive (attempt to control C just prints ^C on the screen).

Now, when I try to open the directory and use the ls command, the command does not complete after several minutes. I cannot access the shell script or any of the files using ls. The directory only has about 30 files are so. How can I fix this, or alternatively just remove the defective directory and screen?

UPDATE: was not able to move the files to a new directory using cp. I also see that there are a couple remnants of the processes viewable in htop activity, but I am unable to kill the process ID.

closed as off-topic by dhag, GAD3R, Archemar, Kusalananda, thrig Mar 2 '18 at 21:49

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – dhag, GAD3R, Archemar, Kusalananda, thrig
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you tried logging into the HPC from a different terminal window? Does it work if you do that? – Time4Tea Feb 26 '18 at 17:56
  • Yes I tried that but I am still unable to use -ls. Right now I am trying to transfer all the files from the directory to a new directory using cp but it is taking a very long time. – MegC Feb 26 '18 at 18:04
  • Ok. Why do you keep saying '-ls'? The command to list a directory contents is just 'ls [directory name]'. – Time4Tea Feb 26 '18 at 18:06
  • sorry, I have edited the original post to fix that. Thanks – MegC Feb 26 '18 at 18:30
  • Perhaps your terminal was botched? Try stty reset – Jeff Schaller Feb 26 '18 at 21:21
0

Restarting the HPC fixed the issue.

  • If by "HPC" you mean a multi-user compute cluster, then what did the other users think of your "solution"? – Kusalananda Mar 1 '18 at 17:43
  • Apparently this had happened previously on the cluster, and some processes were existing in the background that would not be killed even by sigKILL. No other users were using it at the time, so we were able to reset it. – MegC Mar 2 '18 at 20:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.