0

tried to install Hadoop cluster

App Timeline Server Install returned error:

2018-02-26 19:31:49,406 - Installing package hadoop_2_6_1_0_129-hdfs ('/usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_1_0_129-hdfs')
2018-02-26 19:31:51,614 - Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_1_0_129-hdfs' returned 1. Error: Package: hadoop_2_6_1_0_129-hdfs-2.7.3.2.6.1.0-129.x86_64 (HDP-2.6)

Tried to exceute command on server:

 /usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_1_0_129-hdfs
Error: Package: hadoop_2_6_1_0_129-hdfs-2.7.3.2.6.1.0-129.x86_64 (HDP-2.6)
           Requires: libtirpc-devel
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Tried to find libtirpc-devel

yum search libtirpc
Loaded plugins: langpacks, ulninfo
=============================================================================================== N/S matched: libtirpc ===============================================================================================
libtirpc.i686 : Transport Independent RPC Library
libtirpc.x86_64 : Transport Independent RPC Library

installed

 yum install libtirpc.i686
Loaded plugins: langpacks, ulninfo
Package libtirpc-0.2.4-0.10.el7.i686 already installed and latest version
Nothing to do

Tried to install more time and returned again error:

/usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_1_0_129-hdfs
Error: Package: hadoop_2_6_1_0_129-hdfs-2.7.3.2.6.1.0-129.x86_64 (HDP-2.6)
           Requires: libtirpc-devel
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

What else can you try to do?

1 Answer 1

0

As far as I can see from your output the package libtirpc-devel is needed for HDP 2.6. Please take note that libtirpc and libtirpc-devel are different packages. You could search for it i.e. by yum whatprovides libtirpc-devel. Depending on your distribution you may need to enable additional repositories.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .