0

enter image description here

I think I do something wrong and made filesystem mess , please look that pic , I can't boot , it said emergency mode, please exit to the shell

And after I check the logs It said my default.target has a problem:

Failed to start default.target: Transaction is destructive

  • 1
    Could do with more information. How did you extend your filesystem? Are you using LVM? Are you using dm-crypt? Are you referencing your /root partition using UUID or device name? Did you extend the partition or create a larger one? – Pedro Feb 26 '18 at 12:36
  • I really forget and I was follow the website to tell me to create new partipation, think I use vgentend and lvexntend to create it , and fdisk also. – Harmnot Feb 26 '18 at 13:32
1

You're in initrd (=initramfs) emergency shell environment. You should use it to verify the status of your root filesystem. If your root filesystem is LVM-based, you might want to try commands like lvm pvs, lvm vgchange -ay and lvm vgdisplay to get more information about the status of your LVM volume group(s).

(In emergency shell, the typical LVM commands are all packaged into a single lvm binary: to use regular LVM commands, add a lvm <space> prefix to the command you would usually use.)

You can even try and mount your root filesystem manually, and see the error message that probably occurs when you try to do that.

  • It said 2 logical volumes in volumr group "Fedora" active, and when I run lvm pvs , it said could find device with uuid , – Harmnot Feb 26 '18 at 13:33
  • So it is unable to find all the PVs belonging to that VG. I guess you added another disk to the "Fedora" VG that contains your root filesystem. Was the new disk on the same disk controller as the old one(s), or is it on a different controller? Perhaps your initramfs did not include the driver for that disk controller: before this it was not a problem, as that disk controller activation could happen later, after mounting the root filesystem. But now it is needed in the initramfs phase. Boot from installation in rescue mode; if it works, rebuild your initramfs. That should hopefully fix it. – telcoM Feb 26 '18 at 15:18
  • 1drv.ms/u/s!AsmKoEPFnjbNbzKTyeHuJho43pE This is the link when I run gparted on parted magic, how I can fix that ?? – Harmnot Feb 26 '18 at 23:45
  • That is just one LVM physical volume that is part of the "Fedora" volume group. It contains the swap area and at least a part of the root filesystem. It also says there used to be another physical volume (i.e. another disk or partition that was added to the volume group), which cannot be detected now. That one is probably the one which needs fixing. Where is/was it? – telcoM Feb 27 '18 at 7:47
  • I really confused about that, so I re install the fedora, and after this I want to back up my fedora filesystem, how I can backup it? – Harmnot Feb 28 '18 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.