1

I'm running Debian 9 as Host and I installed correctly Windows 7 as guest by using Oracle VirtualBox (v. 5.2.6); both the OSs work fine and I need to have a folder shared between those 2 operative systems.

In order to be able to get this, I followed these steps:

  1. GuestAddition installation, by running, as super-user:

    apt-get install virtualbox-guest-dkms virtualbox-guest-x11 linux-headers-$(uname -r)

  2. Creating the candidate folder /home/quant/Scrivania/VirtualBox/Data by modifying the Oracle VirtualBox Manager settings (Shared Folders);

  3. mounting the device by running:

    mount -t vboxsf Data /home/quant/Scrivania/VirtualBox/Data/

At the point (3), I got the following error message in the terminal:

/sbin/mount.vboxsf: mounting failed with the error: No such device

It seems like the folder does not exist although I manually create the local folder and set it as shared folder in the VirtualBox manager.

Someone could suggest a solution?

Hope I has been clear when I asked the question. Thanks you all in advice!

  • For a sanity check, are the VirtualBox modules loaded (check lsmod|grep vbox)? – ErikF Feb 26 '18 at 4:23
1

I simply solved by following those steps; first of all install Oracle Virtual Box as follows:

  1. run as super-user nano /etc/apt/sources.list.d/virtualbox.list
  2. paste deb http://download.virtualbox.org/virtualbox/debian stretch contrib and after type ctrl+O and ctrl+X to save and quit respectively
  3. run from the terminal:

    • wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | apt-key add -

    • apt update

    • apt-get install virtualbox-5.2

    • apt-get install dkms

After, download the .iso image from the Oracle Repository and choosing the version you need on the basis of your host OS and install GuestAdditions by selecting from the virtual machine window menu

Device > Insert ISO image for GuestAdditions

and follow what suggested by the installation guide. Finally, go through

Devices > Shared Folder

and select the path in which is contained the folder you need to share.

0

Your error: /sbin/mount.vboxsf: mounting failed with the error: No such device could be caused because you are mounting the SF with the same name for the share and mount point. They should be different (i.e share is called ~/share and mount point ~/host) You will also need to make sure you have followed these steps correctly:

  • Create a folder on the Host computer (ubuntu) that you would like to share, for example ~/share
  • Boot the Guest operating system in VirtualBox.
  • Select Devices -> Shared Folders...
  • Choose the 'Add' button.
  • Select ~/share
  • Optionally select the 'Make permanent' option

After you have completed that process, open your terminal on the host and run:

sudo mount -t vboxsf -o uid=$UID,gid=$(id -g) /home/quant/Scrivania/VirtualBox/Data ~/host

(/home/quant/Scrivania/VirtualBox/Data and ~/host may have to be reversed or changed to the appropriate names) If that step completes successfully on your Windows guest you should be able to run:

net use x: \\vboxsvr\[whatever your share folder's name is]

Keep your shared folder name simple such as ~/Data or ~/share instead of /home/quant/Scrivania/VirtualBox/Data as that may be another source for your issue. Good Luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.