-2

When I type the command

./configure --prefix....

the result goes like this :

checking whether the C compiler works... no

configure: error: in `/root/Downloads/agensgraph': 
configure error: C compiler cannot create executables 
See `config.log' for more details

My config.log is the following:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by PostgreSQL configure 9.6.2, which was
generated by GNU Autoconf 2.69.  Invocation command line was

  $ ./configure --prefix=/usr/local/agensgraph --enable-cassert --enable-debug CFLAGS=-ggdb -0g -g3 -fno-omit-frame-pointer

## --------- ##
## Platform. ##
## --------- ##

hostname = cll
uname -m = x86_64
uname -r = 3.10.0-514.el7.x86_64
uname -s = Linux
uname -v = #1 SMP Tue Nov 22 16:42:41 UTC 2016

/usr/bin/uname -p = x86_64
/bin/uname -X     = unknown

/bin/arch              = x86_64
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/agensgraph/bin
PATH: /home/jessica/spark/apache-maven-3.5.2/bin
PATH: /home/jessica/spark/jdk1.8.0_121/bin
PATH: /home/jessica/spark/hadoop-2.7.5/bin
PATH: /home/jessica/spark/hadoop-2.7.5/sbin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/bin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/sbin
PATH: /home/jessica/spark/scala-2.11.6/bin
PATH: /home/jessica/spark/sbt/bin
PATH: /usr/local/agensgraph/bin
PATH: /home/jessica/spark/apache-maven-3.5.2/bin
PATH: /home/jessica/spark/jdk1.8.0_121/bin
PATH: /home/jessica/spark/hadoop-2.7.5/bin
PATH: /home/jessica/spark/hadoop-2.7.5/sbin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/bin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/sbin
PATH: /home/jessica/spark/scala-2.11.6/bin
PATH: /home/jessica/spark/sbt/bin
PATH: /usr/local/agensgraph/bin
PATH: /home/jessica/spark/apache-maven-3.5.2/bin
PATH: /home/jessica/spark/jdk1.8.0_121/bin
PATH: /home/jessica/spark/hadoop-2.7.5/bin
PATH: /home/jessica/spark/hadoop-2.7.5/sbin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/bin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/sbin
PATH: /home/jessica/spark/scala-2.11.6/bin
PATH: /home/jessica/spark/sbt/bin
PATH: /usr/local/agensgraph/bin
PATH: /home/jessica/spark/apache-maven-3.5.2/bin
PATH: /home/jessica/spark/jdk1.8.0_121/bin
PATH: /home/jessica/spark/hadoop-2.7.5/bin
PATH: /home/jessica/spark/hadoop-2.7.5/sbin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/bin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/sbin
PATH: /home/jessica/spark/scala-2.11.6/bin
PATH: /home/jessica/spark/sbt/bin
PATH: /home/jessica/AgensGraph/bin
PATH: /home/jessica/spark/apache-maven-3.5.2/bin
PATH: /home/jessica/spark/jdk1.8.0_121/bin
PATH: /home/jessica/spark/hadoop-2.7.5/bin
PATH: /home/jessica/spark/hadoop-2.7.5/sbin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/bin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/sbin
PATH: /home/jessica/spark/scala-2.11.6/bin
PATH: /home/jessica/spark/sbt/bin
PATH: /home/jessica/AgensGraph/bin
PATH: /home/jessica/spark/apache-maven-3.5.2/bin
PATH: /home/jessica/spark/jdk1.8.0_121/bin
PATH: /home/jessica/spark/hadoop-2.7.5/bin
PATH: /home/jessica/spark/hadoop-2.7.5/sbin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/bin
PATH: /home/jessica/spark/spark-2.2.1-bin-hadoop2.7/sbin
PATH: /home/jessica/spark/scala-2.11.6/bin
PATH: /home/jessica/spark/sbt/bin
PATH: /usr/local/bin
PATH: /usr/local/sbin
PATH: /usr/bin
PATH: /usr/sbin
PATH: /bin
PATH: /sbin
PATH: /root/bin
PATH: /usr/bin
PATH: /usr/local/lib


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2769: checking build system type
configure:2783: result: x86_64-pc-linux-gnu
configure:2803: checking host system type
configure:2816: result: x86_64-pc-linux-gnu
configure:2838: checking which template to use
configure:2908: result: linux
configure:3003: checking whether to build with 64-bit integer date/time support
configure:3032: result: yes
configure:3039: checking whether NLS is wanted
configure:3071: result: no
configure:3079: checking for default port number
configure:3104: result: 5432
configure:3533: checking for block size
configure:3567: result: 8kB
configure:3579: checking for segment size
configure:3608: result: 1GB
configure:3620: checking for WAL block size
configure:3655: result: 8kB
configure:3667: checking for WAL segment size
configure:3702: result: 16MB
configure:3799: checking for gcc
configure:3815: found /usr/bin/gcc
configure:3826: result: gcc
configure:3857: checking for C compiler version
configure:3866: gcc --version >&5
gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-16)
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3877: $? = 0
configure:3866: gcc -v >&5
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/4.8.5/lto-wrapper
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-initfini-array --disable-libgcj --with-isl=/builddir/build/BUILD/gcc-4.8.5-20150702/obj-x86_64-redhat-linux/isl-install --with-cloog=/builddir/build/BUILD/gcc-4.8.5-20150702/obj-x86_64-redhat-linux/cloog-install --enable-gnu-indirect-function --with-tune=generic --with-arch_32=x86-64 --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.8.5 20150623 (Red Hat 4.8.5-16) (GCC) 
configure:3877: $? = 0
configure:3866: gcc -V >&5
gcc: error: unrecognized command line option '-V'
gcc: fatal error: no input files
compilation terminated.
configure:3877: $? = 4
configure:3866: gcc -qversion >&5
gcc: error: unrecognized command line option '-qversion'
gcc: fatal error: no input files
compilation terminated.
configure:3877: $? = 4
configure:3897: checking whether the C compiler works
configure:3919: gcc -ggdb -0g -g3 -fno-omit-frame-pointer   conftest.c  >&5
gcc: error: unrecognized command line option '-0g'
configure:3923: $? = 1
configure:3961: result: no
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "PostgreSQL"
| #define PACKAGE_TARNAME "postgresql"
| #define PACKAGE_VERSION "9.6.2"
| #define PACKAGE_STRING "PostgreSQL 9.6.2"
| #define PACKAGE_BUGREPORT "pgsql-bugs@postgresql.org"
| #define PACKAGE_URL ""
| #define PG_MAJORVERSION "9.6"
| #define PG_VERSION "9.6.2"
| #define AG_VERSION "1.2.0"
| #define AG_GIT_REVISION "355d7fc343f65b6a06247d670b8966253c46bf53"
| #define USE_INTEGER_DATETIMES 1
| #define DEF_PGPORT 5432
| #define DEF_PGPORT_STR "5432"
| #define BLCKSZ 8192
| #define RELSEG_SIZE 131072
| #define XLOG_BLCKSZ 8192
| #define XLOG_SEG_SIZE (16 * 1024 * 1024)
| /* end confdefs.h.  */
| 
| int
| main ()
| {
| 
|   ;
|   return 0;
| }
configure:3966: error: in `/root/Downloads/agensgraph':
configure:3968: error: C compiler cannot create executables
See `config.log' for more details

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=x86_64-pc-linux-gnu
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-ggdb -0g -g3 -fno-omit-frame-pointer'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_DOCBOOKSTYLE_set=
ac_cv_env_DOCBOOKSTYLE_value=
ac_cv_env_LDFLAGS_EX_set=
ac_cv_env_LDFLAGS_EX_value=
ac_cv_env_LDFLAGS_SL_set=
ac_cv_env_LDFLAGS_SL_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=x86_64-pc-linux-gnu
ac_cv_prog_ac_ct_CC=gcc

## ----------------- ##
## Output variables. ##
## ----------------- ##

AR=''
AWK=''
BISON=''
BISONFLAGS=''
CC='gcc'
CFLAGS='-ggdb -0g -g3 -fno-omit-frame-pointer'
CFLAGS_SSE42=''
CFLAGS_VECTOR=''
COLLATEINDEX=''
CPP=''
CPPFLAGS=''
DBTOEPUB=''
DEFS=''
DLLTOOL=''
DLLWRAP=''
DOCBOOKSTYLE=''
DTRACE=''
DTRACEFLAGS=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
ELF_SYS=''
EXEEXT=''
FLEX=''
FLEXFLAGS=''
GCC=''
GCOV=''
GENHTML=''
GREP=''
HAVE_IPV6=''
INCLUDES=''
INSTALL_DATA=''
INSTALL_PROGRAM=''
INSTALL_SCRIPT=''
JADE=''
LCOV=''
LD=''
LDAP_LIBS_BE=''
LDAP_LIBS_FE=''
LDFLAGS=''
LDFLAGS_EX=''
LDFLAGS_SL=''
LIBOBJS=''
LIBS=''
LN_S=''
LTLIBOBJS=''
MKDIR_P=''
MSGFMT=''
MSGFMT_FLAGS=''
MSGMERGE=''
NSGMLS=''
OBJEXT=''
OSX=''
PACKAGE_BUGREPORT='pgsql-bugs@postgresql.org'
PACKAGE_NAME='PostgreSQL'
PACKAGE_STRING='PostgreSQL 9.6.2'
PACKAGE_TARNAME='postgresql'
PACKAGE_URL=''
PACKAGE_VERSION='9.6.2'
PATH_SEPARATOR=':'
PERL=''
PG_CRC32C_OBJS=''
PG_MAJORVERSION='9.6'
PG_VERSION_NUM=''
PORTNAME='linux'
PROVE=''
PTHREAD_CC=''
PTHREAD_CFLAGS=''
PTHREAD_LIBS=''
PYTHON=''
RANLIB=''
SHELL='/bin/sh'
STRIP=''
STRIP_SHARED_LIB=''
STRIP_STATIC_LIB=''
SUN_STUDIO_CC=''
TAR=''
TAS=''
TCLSH=''
TCL_CONFIG_SH=''
TCL_INCLUDE_SPEC=''
TCL_LIBS=''
TCL_LIB_SPEC=''
TCL_SHARED_BUILD=''
TCL_SHLIB_LD_LIBS=''
UUID_EXTRA_OBJS=''
UUID_LIBS=''
WANTED_LANGUAGES=''
WINDRES=''
XGETTEXT=''
XML2_CONFIG=''
XMLLINT=''
XSLTPROC=''
ZIC=''
ac_ct_CC='gcc'
autodepend=''
ax_pthread_config=''
bindir='${exec_prefix}/bin'
build='x86_64-pc-linux-gnu'
build_alias=''
build_cpu='x86_64'
build_os='linux-gnu'
build_vendor='pc'
configure_args=' '\''--prefix=/usr/local/agensgraph'\'' '\''--enable-cassert'\'' '\''--enable-debug'\'' '\''CFLAGS=-ggdb -0g -g3 -fno-omit-frame-pointer'\'''
datadir='${datarootdir}'
datarootdir='${prefix}/share'
default_port='5432'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
enable_coverage='no'
enable_debug='yes'
enable_dtrace='no'
enable_nls='no'
enable_rpath='yes'
enable_tap_tests='no'
enable_thread_safety=''
exec_prefix='NONE'
have_docbook=''
have_win32_dbghelp=''
host='x86_64-pc-linux-gnu'
host_alias=''
host_cpu='x86_64'
host_os='linux-gnu'
host_vendor='pc'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_bin=''
krb_srvtab=''
ld_R_works=''
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
oldincludedir='/usr/include'
pdfdir='${docdir}'
perl_archlibexp=''
perl_embed_ldflags=''
perl_privlibexp=''
perl_useshrplib=''
prefix='/usr/local/agensgraph'
program_transform_name='s,x,x,'
psdir='${docdir}'
python_additional_libs=''
python_includespec=''
python_libdir=''
python_libspec=''
python_majorversion=''
python_version=''
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''
vpath_build=''
with_gnu_ld=''
with_libxml=''
with_libxslt=''
with_openssl=''
with_perl=''
with_python=''
with_selinux=''
with_system_tzdata=''
with_systemd=''
with_tcl=''
with_uuid=''
with_zlib=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME "PostgreSQL"
#define PACKAGE_TARNAME "postgresql"
#define PACKAGE_VERSION "9.6.2"
#define PACKAGE_STRING "PostgreSQL 9.6.2"
#define PACKAGE_BUGREPORT "pgsql-bugs@postgresql.org"
#define PACKAGE_URL ""
#define PG_MAJORVERSION "9.6"
#define PG_VERSION "9.6.2"
#define AG_VERSION "1.2.0"
#define AG_GIT_REVISION "355d7fc343f65b6a06247d670b8966253c46bf53"
#define USE_INTEGER_DATETIMES 1
#define DEF_PGPORT 5432
#define DEF_PGPORT_STR "5432"
#define BLCKSZ 8192
#define RELSEG_SIZE 131072
#define XLOG_BLCKSZ 8192
#define XLOG_SEG_SIZE (16 * 1024 * 1024)

configure: exit 77

closed as off-topic by Rui F Ribeiro, Satō Katsura, Jesse_b, Archemar, Fox Feb 26 '18 at 3:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Rui F Ribeiro, Satō Katsura, Jesse_b, Archemar, Fox
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Do post the config.log contents. I have a hunch that you may not actually have a C compiler installed. – Kusalananda Feb 25 '18 at 9:39
  • Is the config.log clear? – Jessica Feb 25 '18 at 9:52
  • Is -0g a typo? In the logs there is gcc: error: unrecognized command line option '-0g' and this option seems to have passed during configure. – Thomas Feb 25 '18 at 10:01
  • Thank you for your formatting of the config.log and helping me solve my question, so appreciated it. Would you mind teaching me how did formatting the contents of the config.log, thanks a lot. – Jessica Feb 25 '18 at 10:47
  • @Jessica Preformatted text should be indented by 4 spaces. Selecting a bit of text and clicking {} in the formatting tools menu does this automatically. – Kusalananda Feb 25 '18 at 10:49
5

You are setting CFLAGS to

-ggdb -0g -g3 -fno-omit-frame-pointer

Out of these, -0g is not valid. You may have meant -g0 (which would disable the debugging enabled by -ggdb). The later -g3 flag enables debugging again.

  • Thank you very much, the problem is solved now, thanks again. – Jessica Feb 25 '18 at 10:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.