0

I was having some problems with LibreOffice Draw, and since I couldn't find a solution for it I decided to uninstall and do a clean install. If I recall correctly This is what I've used:

sudo apt-get remove --purge libreoffice*

sudo apt-get clean

sudo apt-get autoremove

Restarted my PC and all. The problem is that when I want to install it again via aptitude (apt-get doesnt' work either) using:

aptitude install libreoffice

I get a message saying (text is too long to paste here)

https://pastebin.com/BXTuAqrP

Now i've tried autoremove -s, apt update, upgrade, apt-get install -f, --fix-broken and according to these comands i don't have any broken or held back packages. I've also use Synaptic manager and the Broken package list is empty. I tried install Libreoffice from there but I get the same error. Only a bit more clear.

https://pastebin.com/iRMkywR1

I've enabled all downloads in software & updates and everything.

When I type on terminal

apt search libreoffice

I get this (there are alot of remnants)

https://pastebin.com/Qa5LnuS5

I don't know what to do, or how to delete it! It's driving me insane. I spent hours and hours looking for solutions on the internet, I've tried everything but to no avail!

Im running Debian9

Please do help me out.

  • Welcome to U&L ,You have a mixed sources (Ubuntu 18 + Debian) . Please add the content of your sources.list: cat /etc/apt/sources.list and cat /etc/apt/sources.list.d/*. – GAD3R Feb 25 '18 at 8:29
0

Are you pulling software from non-stretch repositories? I've searched on https://packages.debian.org and can't find a libreoffice-core package that requires libboost-locale1.65.1 as your log indicates. If you are, please try disabling them temporarily and installing libreoffice again.

What is the output of apt-cache policy libreoffice-core? Running this might give you more information on where libreoffice is coming from.

Additionally, apt-get takes regex and not globbing, so removing all libreoffice packages would actually be apt-get purge '.*libreoffice.*'.

Edit: From your third pastebin link it appears you're pulling software from Ubuntu repositories. This is definitely not supported as Ubuntu and Debian software do not mix and most likely the source of your installation woes. I recommend that you purge all Ubuntu components from your system, remove all Ubuntu repositories from apt, run apt-get update; apt-get -f install, and try installing libreoffice again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.