3

My kernel (4.14-amd64) is currently flickering a lot during stage while I simply have a flashing cursor. It is cosmetically annoying, and I would like to disable the graphics from starting until the initramfs is loaded and my proper Intel graphics driver loads.

Basically, I want to pause the initialization of the screen until the initramfs loads my plymouthd, or maybe later.

I've read so much info about this, I can't link it all.

EDIT1: I don't mind if the grub2 screen stays frozen during this stage.

EDIT2: I have Debian 9 Stretch with a backports kernel.

EDIT3: This is my first question on this community. Feel free to correct me if this is a bad question, etc.

EDIT4: My computer is Acer R3-131T with Intel Integrated Graphics.

2
  • You did not specify on what hardware you have this problem. Also, did you try with other kernel versions? Mar 16, 2018 at 5:26
  • I am using an Acer R3-131T with Intel Integrated Graphics. I tried other kernels but my guess is that I need to compile a kernel without framebuffer support..?
    – Hack5
    Mar 16, 2018 at 9:22

2 Answers 2

1

You could try nomodeset as kernel boot parameter. This does not prevent output but prevents tge kernel from switching graphics card modes.

2
  • I have tried this; it worked (mostly) until plymouth actually loaded, but when it did, the top left block of the animation was black with a console cursor.
    – Hack5
    Mar 17, 2018 at 7:43
  • 1
    The thing is, having nomodeset won't prevent a service or software from loading FB-module as boot process progresses. It simply prevents Linux kernel from changing modes at boot time. Mar 20, 2021 at 13:47
0

i915.modeset=0 along with nouveau.modeset=0 should work for Intel drivers. A good write up on the available configuration options for Intel GFX chipsets can be found here

5
  • This answer is similar to the answer above; they both do the same thing on my laptop. Neither do what I want!
    – Hack5
    Mar 18, 2018 at 8:46
  • Yes, have you tried to do both? And perhaps add in a nouveau.modeset=0?
    – jas-
    Mar 18, 2018 at 11:44
  • I tried both. I have no nouveau/nvidea chips at all
    – Hack5
    Mar 18, 2018 at 18:15
  • Did you read the link provided? I hate asking but this bit seems like it might be needed wiki.archlinux.org/index.php/…
    – jas-
    Mar 19, 2018 at 1:05
  • I'm on debian so there is no mkinitcpio, but I have read through the page from your comment page already, and nothing suggested there helps. The page in the answer doesn't seem to suggest any method to disable the console cursor or to remove flicker from KMS.
    – Hack5
    Mar 19, 2018 at 8:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .