-1

I have a fresh install of kde neon. I started having issues with the system. I couldn't open system settings. Shortcuts weren't working. Some applications weren't starting (like kolourpaint) and right-clicking konsole made it crash.

I rebooted and now it's only a black screen but I can see the cursor.

Maybe what caused the problem is that I did sudo apt install kio-extras

Any guesses? I'm trying to get any useful information from the tty. I tried to restart sddm.

I purged kio-extras and rebooted but that didn't work.

Konsole and kolourpaint were giving me this error respectively

Cannot mix incompatible Qt library (version 0x50903) with this library (version 0x50a00)
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = konsole path = /usr/bin pid = 14146
KCrash: Arguments: /usr/bin/konsole 
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from 
kdeinit
sock_file=/run/user/1000/kdeinit5__0

$ kolourpaint
Empty filename passed to function
Cannot mix incompatible Qt library (version 0x50903) with this library (version 0x50a00)
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kolourpaint path = /usr/bin pid = 13068
KCrash: Arguments: /usr/bin/kolourpaint 
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0
Killed

closed as off-topic by Jeff Schaller, Michael Homer, DarkHeart, Archemar, Wouter Verhelst Mar 5 '18 at 10:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Michael Homer, DarkHeart, Archemar, Wouter Verhelst
If this question can be reworded to fit the rules in the help center, please edit the question.

0

I'm not precisely sure how exactly this happened, but the problem was a partial update. Some packages were updated without others. KDE neon devs have very recently changed from qt 5.9.3 to 5.10

So the solution was get to the tty (Ctrl+Alt+F1) then connect to the internet (sudo ifconfig enp3s0 up where enp3s0 is the name of the network interface, you can list them by just typing ifconfig) and finally do a sudo apt update

I had this problem also happen on another machine. It was updating and the electricity went out and when it came back the fix was the same procedure.

Not the answer you're looking for? Browse other questions tagged or ask your own question.