3

Hi tried to use telnet in High Sierra, and I noticed it does not come anymore with MacOS.

I also attempted to install it via MacPorts with:

$ sudo port install telnet
Error: Port telnet not found

But it did not work. What to do?

6

After investigating a little, I found from a ticket opened in the MacPorts bugtracker: telnet port request (High Sierra) about the lack of telnet, and that the needed package is inetutils.

So I installed inetutils with:

sudo port install inetutils

And know I already can use telnet.

PS. If Homebrew is your thing, you can also install telnet with:

brew install telnet
  • 2
    Curious... why do you choose MacPorts over HomeBrew? – Christopher Feb 23 '18 at 16:52
  • 1
    already installed here, More flexibility, more ports, more stable, no ruby, it does not overwrite MacOS setups/binaries. Though reputedly HomeBrew is simpler, and MacPorts more sysadmin oriented. – Rui F Ribeiro Feb 23 '18 at 16:54
  • 1
    HomeBrew (non-cask) doesn't overwrite MacOS binaries, either: It installs everything into /usr/local and manages it just like I do (manually) on my Debian machine. I haven't tried MacPorts, but so far I found HomeBrew quite sufficient. – dirkt Feb 24 '18 at 8:53
  • @dirkt Fun fact: actually I started using MacPorts to have WireShark and dsniff...then I liked it. – Rui F Ribeiro Feb 24 '18 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.