1

I have been trying for several hours to get to the desktop in Wheezy (amd64 and i386) on Virtualbox but when I execute: startx i just get a slightly different looking prompt.

Do I have to do something before I can access X?

Contents of /var/log/installer/syslog : http://pastebin.com/5ZwpbFxR

service gdm3 start
service gdm start
service kde start

All result in unrecognized service error messages

  • Did you install your Debian with Desktop Environment? Does it not load on start up? How come you end up in terminal without GUI? – SkyDan Jul 8 '12 at 19:04
  • Yes- i ticked the 2 options (I forget exactly what they were)- something like "Desktop Environment" and "Standard Utilities" – Lee Tickett Jul 8 '12 at 19:05
  • No idea why it doesn't load on startup- that's essentially my question. – Lee Tickett Jul 8 '12 at 19:06
  • Try service gdm3 start as root and append the output, if any, to your post. – SkyDan Jul 8 '12 at 19:09
  • May be xdm. Try that instead of gdm. More options include kdm, lxdm... dont' recall others. – killermist Jul 8 '12 at 19:17
2

Try apt-get install task-gnome-desktop. From your logs, the DM/DE was not installed, although Desktop task was selected. This is probably a bug.

Is there any reason you are using testing version of Debian? That's why it's called testing -- because nothing is quite working yet the way it should.

  • I will try that after a fresh install (i have been messing around with it so much i feel it's tainted :). To do with a Raspberry Pi / Gambas3 / DomotiGa / Other project i'm working on- need to use wheezy rather than squeeze. – Lee Tickett Jul 8 '12 at 19:51
  • Thank you very much for your help. A couple of steps and all working now! – Lee Tickett Jul 8 '12 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.