0

Trying to setup the "mirror mode" of 2 OpenLDAP instances on 2 separate servers. But slapd failed to start due to the new added directives. Below is error msg in /var/log/ldap.log:

  /etc/openldap/slapd.conf: line 127: unknown directive <syncprov-checkpoint> inside backend database definition.

Below is the ENV:

# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.3 (Maipo)
# rpm -qa | grep openldap
openldap-devel-2.4.40-13.el7.x86_64
openldap-2.4.40-13.el7.x86_64
openldap-servers-2.4.40-13.el7.x86_64
openldap-clients-2.4.40-13.el7.x86_64
# ps -ef | grep slapd
root       2224      1  0 Feb17 ?        00:00:10 slapd

Below are the sync part in /etc/openldap/slapd.conf file on the server:

# Load dynamic backend modules:
# Module syncprov.la is now statically linked with slapd and there
# is no need to load it here
modulepath /usr/lib64/openldap

...

# enable monitoring
#database monitor

# allow onlu rootdn to read the monitor
#access to *
#        by dn.exact="cn=Administrator,dc=example,dc=com" read
#        by * none
syncprov-checkpoint 100 10
syncprov-sessionlog 100

serverID    1

syncrepl      rid=001
              provider=ldap://10.1.10.19
              bindmethod=simple
              binddn="cn=Administrator,dc=example,dc=com"
              credentials=ldap
              searchbase="dc=example,dc=com"
              schemachecking=on
              type=refreshAndPersist
              retry="60 +"

mirrormode on

loglevel -1
1

This issue is resolved today by myself. It turns out that the comment on "syncprov.la" is "accidentally" wrongly added. Don't know who and why.

After re-reading the manual and add the "moduleload syncprov.la" on both servers, it is resolved.

It is no wonder no one ever post same question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.