0

I tried to configure my trackpoint sensitivity on my ArchLinux using the systemd path unit as described here: https://wiki.archlinux.org/index.php/TrackPoint#systemd.path_unit

My files look like this:

/etc/systemd/system/trackpoint_parameter.path
-----
[Unit]
Description=Watch for, and modify, Trackpoint attributes

[Path]
PathExists=/sys/devices/platform/i8042/serio1/serio2/sensitivity

[Install]
WantedBy=default.target

And

/etc/systemd/system/trackpoint_parameter.service
-----
[Unit]
Description=Set TrackPoint attributes

[Service]
ExecStart=/usr/local/bin/trackpoint_configuration.sh

So I enabled the path unit and since the file exists my script is executed. Until now everything worked as expected. But when I boot my laptop the path unit is started (according to its status after booting), but it never triggered the service (according to its status) and hence the script is not executed.

If I disable the path unit again (after it booted unsuccessful), suddenly the service unit is triggered.

Does anyone know what I'm doing wrong/how I can dig deeper?

  • Do you actually have a /sys/devices/platform/i8042/serio1/serio2/ directory? On my system, serio1 and serio2 are separate directories underneath of i8042. – ErikF Feb 23 '18 at 4:35
  • The directory exists. – Marvin Feb 23 '18 at 10:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.