I have a CentOS image on VirtualBox running on my local machine. (I created a group hadoop and user hduser to run Hadoop services on it.) I created a folder on my MacOS called shared. I did the same in the the VirtualBox image (under user hduser).

The directories are successfully mounted in the sense that I can see all files in shared from both machines. I can create and paste new files into shared on my local machine, but I cannot do the same in the virtual machine.

There seems to be a write permission error, as I can see all files, but cannot write. Below is me testing to write a file in shared on the virtual machine.

[Error writing shared/test.txt: Permission Denied]

Error writing shared/test.txt: Permission Denied

Here's the permissions:
Attempting to write to shared.


Here's my /etc/fstab: enter image description here

I have read up on the issue and tried several things from:

  • 1
    Please don't post images of text. Copy and paste the text itself into your question and format it as code by selecting it and pressing Ctrl-K or by using the editor's {} icon. BTW, since this has nothing to do with nano, you don't need a screenshot of nano either - touch shared/test.txt would have shown the problem, and grep shared /etc/fstab would have shown the relevant fstab entry.
    – cas
    Feb 22 '18 at 22:22
  • @cas Okay, I wasn't aware. I did attempt to add the text from the images in my post. Thanks.
    – usr
    Feb 23 '18 at 10:37

I have managed to solve the issue. I initially followed the instructions from this github post where it is suggested to use these settings:

shared    /home/hduser/shared    vboxsf   defaults,uid=1000,gid=1000,umask=0022    0    0

However, that didn't work in my case. Instead it is either:

shared    /home/hduser/shared    vboxsf   uid=1001 defaults    0    0


shared    /home/hduser/shared    vboxsf   uid=1000 defaults    0    0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.