0

I am currently trying some Ubuntu-Server based projects and want to use some floppies for it. But after installing Ubuntu-server16.04 LTS on my machine, I got an error on start-up:

floppy0: no floppy controllers found

But I can't solve the problem... afaik there could be an kernel error, but I just started using Ubuntu and am just at the beginning.

  • Do you have a floppy controller? – Stephen Kitt Feb 21 '18 at 16:26
  • i think so - ive build in a floppy drive and connected it with IDE-Cable – dor_ sax Feb 21 '18 at 16:32
  • vi /etc/modprobe.d/aliases, find the line alias block-major-2 and comment it, or manually add the line(if it does not have) alias block-major-2 off and reboot. There is an ancient question at Ubuntu launchpad that nobody seems to care about the subject - answers.launchpad.net/ubuntu/+source/grub2/+question/155343 – user34720 Feb 21 '18 at 16:57
  • The /etc/modprobe.d/aliases got me no file, so had to create it and just added the line. But this didn't work, the problem is still occuring – dor_ sax Feb 21 '18 at 17:10
  • Does your motherboard have a floppy drive connector (it's a 34-pin connector and is smaller in size than an IDE connector)? If you managed to plug an IDE cable into a floppy disk drive, it shouldn't have fit very well! – ErikF Feb 21 '18 at 21:05
3
  1. sudo gedit /lib/udev/rules.d/80-udisks.rules (in my Xubuntu 16.04 - 80-udisks2.rules)
  2. search strings and replace them with 0 to 1

# PC floppy drives # KERNEL=="fd*", ENV{ID_DRIVE_FLOPPY}="0"

# USB floppy drives # SUBSYSTEMS=="usb", ATTRS{bInterfaceClass}=="08", ATTRS{bInterfaceSubClass}=="04", ENV{ID_DRIVE_FLOPPY}="0"

  1. Create folger

sudo mkdir /media/floppy

sudo chmod 777 /media/floppy

  1. sudo gedit /etc/fstab

  2. add a line to the end:

/dev/fd0 /media/floppy auto rw,user,noauto,exec,utf8 0 0

  1. sudo gedit /etc/modules

  2. add a line to the end:

floppy

  1. then either reboot the system or perform

sudo modprobe floppy

Edit: I supplemented my answer

  • check if the floppy module is loaded:

lsmod | grep -i floppy

If it returns floppy then you have the floppy module loaded

  • load the floppy module:

sudo modprobe -v floppy

lsmod | grep -i floppy

  • Try adding your username in the floppy group:

sudo adduser $USER floppy

  • Try

udisks --mount /dev/fd0

PS. Floppy WILL NOT auto launch a window when inserted, they were made before that! You will need to go to nautilus and double click on it. You need to unmount before inserting a new floppy disk. Your next floppy you insert won't mount.

  • another way:

udisks --mount /dev/fd0

if not at all - try to install fdutils

and fdmount seems useful. Try: sudo fdmount -l

more ways I do not know and have not tried:)

  • Thank you for your answer! I did what you said, except for the first path (I installed udisks2 already), but in the end modprobe floppygets me the following error: modprobe: ERROR: could not insert 'floppy': No such device – dor_ sax Feb 21 '18 at 17:40
  • I got the feeling, that either a controller is not working proberly or I connected it in a wrong way..? – dor_ sax Feb 21 '18 at 17:41
  • I supplemented my answer – Alex_Krug Feb 21 '18 at 18:38
  • thank you. fdmount says: drive fd0 does not exist... I think, my Problem is on another level than mounting it. Although I want to thank you! (didnt know fdutils till now) – dor_ sax Feb 21 '18 at 21:27
3

After I tried all your suggestions yesterday, I finally found an entry in my BIOS, which said: Floppy Legacy: Disabled. Changed it to 1.44 MB, now everything is fine.

Not the answer you're looking for? Browse other questions tagged or ask your own question.