I'm having trouble hearing anything at all under Fedora 16 on this Lenovo T520. Everything in alsamixer is at 100% (both pulseaudio and card). I installed Windows 7 on the laptop to check if the same issue is present on windows, and it's not.

Does anyone know how to deal with this? I've been annoyed by this problem for almost a year, but now with the heat wave on the east coast, I have to run my AC at full blast and I can't hear anything with the AC on.

Under audacity I can get definitely get high volume out of my speakers by just mixing up the sound volume. Is there a way to run a software amplifier between PulseAudio and alsa to crank up the volume or is there something that can be done in alsactl.conf to get the card to normalize the sound volume scale at a lower point? Since this laptop is quite common among Linux users, I would hope that someone has come up with a solution.

  • Or try a different kernel version? -- bugzilla.altlinux.org/show_bug.cgi?id=23705 Dec 14, 2012 at 8:59
  • Did you ever tried alsamixer through command line? some time GUIs doesn't work properly! I had same problem on my dell laptop which solved by justify PCM column to 100%. Jan 5, 2013 at 9:01
  • Perhaps volume turned down with some physical wheel thingy? Happened to me once...
    – vonbrand
    Feb 4, 2013 at 18:48
  • Do you use fedora 16 default (gnome)? Did you try gnome-control-center sound and maxing out the volume-bar at the bottom?
    – xx4h
    Feb 12, 2013 at 19:54
  • funny, i have an identical setup (520/F16) with no sound issues
    – amphibient
    Mar 23, 2013 at 2:34

4 Answers 4


I've done this in the past and have had pretty good success with boosting the volume up. The only problem with it is if you turn it down, then you'll have to come back into the system preferences under the speaker icon to turn it back up to 150%.

However with the steps below should remain "sticky" from reboot to reboot.

                                     ss #1

Turning up the volume

If you right click on the speaker applet and select sound preferences you'll bring up this dialog.

          ss #2

confirming and saving changes

Turn the volume all the way up to 150%. Once it's been turned up you can close this dialog. If you go to a shell and type the command amixer you can confirm this:

$ amixer 
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Front Left: Playback 98304 [150%] [on]
  Front Right: Playback 98304 [150%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [off]
  Front Right: Capture 65536 [100%] [off]

If you then run this command you can save this state out so that the next time you restart your system, it will be the default.

# saves settings
$ sudo alsactl store

# confirm file's created
$ ls -l /etc/asound.state 
-rw-r--r-- 1 root root 4761 Oct  5 16:54 /etc/asound.state

Other things with amixer

You can use the command amixer to change the volume as well.


$ amixer sset Master 100% | grep Front
  Playback channels: Front Left - Front Right
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]


$ amixer sset Master 150% | grep Front
  Playback channels: Front Left - Front Right
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]

NOTE: This method doesn't allow you to go higher than 100%, however.


$ amixer sset Master muted | grep Front
  Playback channels: Front Left - Front Right
  Front Left: Playback 65536 [100%] [off]
  Front Right: Playback 65536 [100%] [off]


$ amixer sset Master unmuted | grep Front
  Playback channels: Front Left - Front Right
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
  • 1
    "The only problem with it is if you turn it down, then you'll have to come back into the system preferences under the speaker icon to turn it back up to 150%." This is what I'd really like to avoid. What I want is for the speaker icon volume slider to be changed, either to have a higher maximum or to be permanently boosted.
    – mattdm
    Oct 5, 2013 at 21:24
  • @mattdm - I kind of figured that's what you were after but I figured I take a shot and provide this method that I've used. I'll keep digging, see if I can turn something else up.
    – slm
    Oct 5, 2013 at 21:27
  • @mattdm - this has frustrated me at times too. Seems like there should be something better, if you find anything out, even with the plugins route, please share back here. I'd be curious to know it too!
    – slm
    Oct 10, 2013 at 0:59
  • Did someone explain why it happens in the first place and why we can't just fix the issue instead of working around it? Jan 19, 2015 at 16:55
  • @PavelŠimerda - you can see what was discussed about this through out this Q/A. No one ever mentions it and I've continued to use this workaround on Fedora 19 on the same hardware. I should mention that I've used this workaround maybe 2+ times since moving to F19 Dec/2014 so it's not like it's killing me. Just my $0.02.
    – slm
    Jan 19, 2015 at 17:40

From what I know you can use the softvol plugin for ALSA and set the max_dB value. Something in direction of:

pcm.!default {
    type        plug
    slave.pcm   "softvol"

pcm.softvol {
    type    softvol
    slave {
        pcm "hw:0,0"
        # pcm   "dmix" or this or the like.
    control {
        name    "PreAmp"
        card    0
    min_dB  -5.0
    max_dB  30.0  # 50.0 is max
    resolution 16

Perhaps some hints here as well. Then reload alsa, play e.g. speaker-test -c2 -twav to get it loaded and then adjust amp in alsamixer.

If one want to shut down PulseAudio, remember to deactivate autospawn.

echo autospawn=no >> ~/.pulse/client.conf

or uncomment it in the global client.conf (in /etc/pulse/ or the like). (Have also seen some replace daemon-binary with /bin/true.)

However using pactl etc. would perhaps be more preferable.

From commandline say:

pactl set-sink-volume 0 65536   # 100%
pactl set-sink-volume 0 98304   # 150%
pactl set-sink-volume 0 131072  # 200%
                      | |
                      | +----- Based on volume steps
                      +------- Sink number

To list and identify sinks say:

pactl list sinks
pacmd list-sinks # a bit more verbose, and list "volume steps"

As always man and pacmd -h, pactl -h.

To set default volume to e.g. 150% edit ./pulse/default.pa and add the line:

set-sink-volume 0 98304
                +-- (Use full name if one e.g. have multiple USB-soundcards.)

For convenience add an alias or a short script to set this value when ever you want.

To restart PA say pulseaudio -k, and pulseaudio --start.

Another option would be to look into plugins e.g. LADSPA and shw in ALSA or PulseAudio.


OK. Came to think about it. This might be suitable. (Don't know how it escaped me first time around.)

  1. In default.pa add a Pulse Audio module from Device Drivers.
  2. Restart Pulse Audio.
  3. Open Sound settings and set volume for original sink to e.g. 150%. (Or do this by commandline or pre-set it in default.pa as described above.)
  4. Select the new module/sink as device for sound output.

This will give you 150% as 100% when using the normal volume meter.

Example – using module-remap-sink:

Do not uncomment as the doc say.

In default.pa:

.ifexists module-remap-sink.so
# Using remap-sink as dummy, not doing any re-mapping.
load-module module-remap-sink sink_name=VolDummy master=0 sink_properties=device.description=CrankThaVolume

# Set it as default:
set-default-sink VolDummy

Then restart Pulse Audio to get the new module registered.


$ pactl list modules # Should show "Usage counter: 1" for the module in question.
$ pactl list sinks

should show a new sink. You can still crank the volume for master by using command-line and/or adding lines to default.pa.

  • Yeah, it looks like the set-sink-volume approach is the best that can reasonably be done, and it doesn't address the real want. Oh well. I'll look into plugins and see what they might be able to do for me.
    – mattdm
    Oct 8, 2013 at 23:03
  • @mattdm: Yes. Added a new solution that might fit your needs better.
    – Runium
    Oct 9, 2013 at 3:55

When running alsamixer from the command line, be sure to run with the --view all switch to ensure you're looking at all available mixer controls.

alsamixer -V all

Also, press F6 in alsamixer and check the settings for each device listed.


I had a similar problem one time in Fedora 18. Turned out Google's "pepperbox" API for Flash had some serious issues with sound, and I solved it by going into /home//.config/google-chrome and killing PepperFlash, then reinstalling flash plugins from Adobe.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.