0

I'm using Pycharm IDE on the Linux Debian 9 stretch OS and getting the following error when I try to install the python Debugger extension (Cython).

The error I get is the following one:

Gtk-Message: Failed to load module "canberra-gtk-module"

I think this is due to the fact that the OS didn't have the module/package suggested by the error message.

So I ran on the terminal:

sudo apt-get install libcanberra-gtk3-module

and, alternatively, I ran:

sudo apt-get install libcanberra-gtk-module:i386

in the hope that the 32-bit version worked better than the 64-bit one (I run a 64-bit version).

Woefully, in the first case, I got that this package is already installed, while in the second one the terminal response stated that is not possible to find such package.

Moreover, the error comes out only when I run PyCharm from the terminal, not in other cases; by running:

sudo apt-get update && sudo apt-get upgrade

everything goes right and there are no error message in the terminal.

What is the package I need installing?

  • Please don’t use links as crutches, and don’t say “I tried _____” and then link to a question with four answers. Say what you tried and what happened. – G-Man Feb 20 '18 at 23:40
  • Hi @G-Man! Thanks for commenting. I'm sorry for asking the question wrong; I edited the question in the hope to explain better my problem. Let me know whether you have other advices. – Quant.Pi Feb 21 '18 at 8:31
2
sudo apt-get update
sudo apt-get install libcanberra-gtk-module
0

The package you need to install is the development package. The exact name may be depended on the version of your repository. At present on Ubuntu 18.04 it is named: libcanberra-gtk-dev

You can use this command to list the names as well as which components you currently have installed (the command and output from my system):

$ apt search libcanberra-gtk | egrep ^libcanberra-gtk
libcanberra-gtk-common-dev/bionic,bionic,now 0.30-5ubuntu1 all [installed,automatic]
libcanberra-gtk-dev/bionic,now 0.30-5ubuntu1 amd64 [installed]
libcanberra-gtk-module/bionic,now 0.30-5ubuntu1 amd64 [installed,automatic]
libcanberra-gtk0/bionic,now 0.30-5ubuntu1 amd64 [installed,automatic]
libcanberra-gtk3-0/bionic,now 0.30-5ubuntu1 amd64 [installed,automatic]
libcanberra-gtk3-dev/bionic 0.30-5ubuntu1 amd64
libcanberra-gtk3-module/bionic,now 0.30-5ubuntu1 amd64 [installed,automatic]

Installing the dev library will normally automatically install the other depends.

  • On Ubuntu 18.04 , libcanberra-gtk-module is provided only by libcanberra-gtk-module or libcanberra-gtk3-module. – GAD3R May 9 '18 at 19:03
  • @GAD3R libcanberra-gtk-module is automatically installed in Ubuntu as part of the OS without any action from the user. When you install libcanberra-gtk-dev the libcanberra-gtk-module is, as you can see in my answer installed,automatic. There is a good chance, since libcanberra-gtk-module is already installed by default when during the Ubuntu installation, there are components from his IDE programming environment that is dependant on some components of the development package. I don't believe sudo apt-get install libcanberra-gtk-module will make a difference. – L. D. James May 9 '18 at 19:23
-1
sudo apt-get install libcanberra-gtk*
  • 2
    Could you please update your post to include more context to your answer? Simply format the command properly and state why you think this is the correct answer. – kemotep Apr 2 '18 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.