2

I'm trying to install ccrypt on centOS, but I'm getting the following error:

yum install ccrypt
No package ccrypt available.

I tried to download the rpm and install it manually but it will require to install dependencies one by one (not very efficient).

I also tried installing the latest EPEL as mentioned here still same error

What shall I do?

I'm new to yum and CentOS, coming from Debian based flavors.

migrated from serverfault.com Feb 20 '18 at 21:44

This question came from our site for system and network administrators.

3

-- Scrap that on CentOS6, it's only available for v7.

ccrypt is available in EPEL (an extended package repository), so you have to activate it first.

sudo yum install epel-release 
sudo yum update 
sudo yum install ccrypt 
  • 1
    nope that still did not work; I already installed epel previously but I did exactly what you posted and it did not work – AK_ Feb 9 '18 at 10:13
  • ccrypt seems to be only available in EPEL for CentOS 7, not CentOS 6. – Gerald Schneider Feb 9 '18 at 10:16
  • @GeraldSchneider: You are right, I missed the centos6 tag. – Sven Feb 9 '18 at 10:18
  • 1
    @AK_: If you are new to CentOS, why do you start with such an old version? – Sven Feb 9 '18 at 10:19
  • any alternative for ccrypt on centos6? – AK_ Feb 9 '18 at 10:25
0

Answering my own question: It seems that you cannot install ccrypt via packages. The only way to get it working was to:

  • download precompiled tar.gz file from here
  • chown user:user * all files to my current username
  • I was then able to run ccrypt
0

if you don't want to add the epel-release in your repolist you should go to this address

http://ccrypt.sourceforge.net/ and download the binary rpm and do this example commands

rpm -Uvh ccrypt-1.11-1.x86_64.rpm

done

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.