1

I can't update, upgrade or install anything at the moment because I get an error:

dpkg: unrecoverable fatal error, aborting:
files list file for package 'x11-common' contains empty filename
E: Sub-process /usr/bin/dpkg returned an error code (2)

I have tried to fix it but no success with that one. Also tried to reinstall but that failed with the same error. Is there anyway to fix this or am I doomed? I'm running Debian 9.

2

The error message means that the /var/lib/dpkg/info/x11-common.list file was corrupted somehow. To fix this, delete it:

sudo rm /var/lib/dpkg/info/x11-common.list

and then re-install the package:

sudo apt --reinstall install x11-common
  • Thank you that took care of the problem, but for some reason it's trying to uninstall jitsi-meet-prosody also with that second command. I have tried to uninstall that one before without success and in the end I have error: prosody.service is not active, cannot reload. invoke-rc.d: initscript prosody, action "reload" failed. dpkg: error processing package jitsi-meet-prosody (--remove): subprocess installed post-removal script returned error exit status 1 – Mira Feb 20 '18 at 10:26
  • I might need to make another seperate question about that one. – Mira Feb 20 '18 at 10:34
  • It looks like there’s more stuff broken — the prosody.service error is probably the result of the previous removal attempt, and not related to the x11-common re-installation. You should indeed ask a separate question... – Stephen Kitt Feb 20 '18 at 10:38
  • Yes, I thought so as well. Thank you for your help! – Mira Feb 20 '18 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.