2

I have bought a Lenovo IdeaPad Y700 some time ago, I installed Ubuntu 16.04 on it and everything worked great.

Problem started when I hibernated the laptop (battery level was low). Since then my NVIDIA GeForce GTX 950M refused to boot with Nouveau driver. Furthermore, when I try to install or run any installed Linux OS, I get the following errors:

Error message

I was not able to find any answer that would fit my situation. This issue is present both with Arch and Debian based systems (even when installer is just launched and installation is not yet started)

[20-02-2017] EDIT

I installed Windows 10 to check whether it's an OS issue or a graphic card issue and I was able to successfully install Nvidia drivers and configure graphic card, so it's rather a Linux issue.

[25-02-2017] EDIT

As suggested by @dirkt below are the logs after Ubuntu 16.04 installation

  • For clarification: Everything else works, just the nouveau driver fails to load? In particular, you can log in via console? If yes, please do so, save the complete output of dmesg somewhere (e.g. USB stick), upload to a pastebin etc. and edit question with link. Also, edit your question with the output of lspci -vv -s 1:0.0 The last lines show a PCIe read error of the graphics card after a timeout, so I suspect the PCI setup fails, which may or may not be related to the ACPI error. – dirkt Feb 24 '18 at 16:42
  • 1
    When I install nouveau driver then the X server will not launch. And yes, I can lon in via console when this happens. I'll install Ubuntu 16.04 and attach these logs, along with screenshot with an error after driver installation – VanDavv Feb 25 '18 at 16:11
1
+100

As dirkt mentioned it might be kernel issue, but it should not affect driver installation itself.

You can try to install official nvidia drivers from graphics driver ppa

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update    

and then install the drivers:

sudo apt-get install nvidia-387
  • 1
    It worked, I must had been using driver not from this ppa. I was thinking if I should accept this answer (since ACPI error still occurs) but right now it rather cosmetic issue for me than a blocker, so I'm marking as accepted – VanDavv Feb 26 '18 at 10:59
2

Partial answer:

The Nvidia card is correctly enumerated, but this

[    0.319197] pci 0000:01:00.0: can't claim BAR 6 [mem 0xfff80000-0xffffffff pref]: no compatible bridge window
[    0.319215] pci 0000:01:00.0: BAR 6: no space for [mem size 0x00080000 pref]
[    0.319216] pci 0000:01:00.0: BAR 6: failed to assign [mem size 0x00080000 pref]
[    0.319217] pci 0000:00:01.0: PCI bridge to [bus 01]
[    0.319219] pci 0000:00:01.0:   bridge window [io  0xd000-0xdfff]
[    0.319221] pci 0000:00:01.0:   bridge window [mem 0xd1000000-0xd1ffffff]
[    0.319223] pci 0000:00:01.0:   bridge window [mem 0xa0000000-0xb1ffffff 64bit pref]

suggests that there is something off with the pci-to-pci bridge that is used to access the graphics card.

This here

[    1.028760] ACPI Warning: \_SB.PCI0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[    1.028792] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[    1.028867] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[    1.028918] pci 0000:01:00.0: optimus capabilities: enabled, status dynamic power, hda bios codec supported
[    1.028920] VGA switcheroo: detected Optimus DSM method \_SB_.PCI0.PEG0.PEGP handle

indeed looks like something goes wrong in the ACPI, and GFX0 and PEG0 are probably graphic card sections. The wrong ACPI may also cause trouble with the pci-to-pci bridge.

So very likely the BIOS provides slightly different ACPI information after the hibernation (for whatever reason), and Linux chokes on that, while Windows doesn't.

So the next step would be to debug the ACPI, which isn't fun, and I'm not expert at that. Possibly you could take this to the kernel people who are responsible for the ACPI interpretation, file a bug and see if someone finds it interesting enough to have a look.

1

Honestly, I don't think ACPI Error: AE_NOT_FOUND errors are the (main) cause of your problem, that's installing Linux on that system. I have a bunch of very similar errors (ACPI related) but my system works fine...

Anyway, try to boot Linux with acpi=off kernel parameter, let's give it a try!

Second, do you have latest BIOS/firmware installed? Since ACPI is related to low-level software, it's important you have the latest.

Third, having graphics driver installed does not mean anything worth! Did you try to launch a 3D program/game in order to check that?

  • 1
    I need to have drivers installed, since I'm using NVIDIA CUDA Toolkit, which, along with Tensorflow GPU allows me to parralelize matrix multiplication on GPU. And yes, latest BIOS is installed – VanDavv Feb 25 '18 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.