I upgraded to plasma 5.12 and the global menus disappeared, and the entry in settings also disappeared.

Application Style ⇒ Widget Style ⇒ Fine Tuning

I tried deleting the plasma* files from ~/.config and also the whole ~/.kde folder thinking it may be some misconfiguration, but none of this helped.

comparison before and after


5 Answers 5


According to announcements you need to add the corresponding Plasma Widget or the menu button from "Window Decorations" settings.

Global Menus have returned. KDE's pioneering feature to separate the menu bar from the application window allows for a new user interface paradigm, with either a Plasma Widget showing the menu, or with the menu neatly tucked away in the window title bar. Setting it up has been greatly simplified in Plasma 5.12: as soon as you add the Global Menu widget or title bar button, the required background service gets started automatically. No need to reload the desktop or click any confirmation buttons!

Step by step instructions:

From the Application Dashboard/Launcher/Menu, select "Settings" (in the Launcher: under "Applications") → "System Settings" → "Application Style" → "Window Decorations" → "Titlebar Buttons"; then drag and drop the "Application menu" icon to the titlebar.


As mentioned briefly in the main answer, although global menus in window titlebar has been replaced by the panel widget "Global menu", they are still available in the window titlebar as a button.

System Settings > Application Style > Windows Decorations > (tab) Buttons - there drag "Application" button on the window bar. Preferably remove the "Menu" button as they look the same.

enter image description here

enter image description here

In Chrome it look like this:

enter image description here:

In Kubuntu 18.04 with Plasma 5.12 and Libreoffice 6.0.7 if any global menus are enabled (panel widget or window button), Libreoffice loses its menubar.


I fixed this annoying as heck issue from displaying the menu in for the application on the desktop by disabling this:

Background Services / Application menus daemon

  • 2
    Thanks loads, I've encountered this countless times, seems some apps when you uninstall them enable Application menus daemon.
    – Kreezxil
    Apr 1, 2021 at 1:36
  • 1
    Thanks, for this answer!
    – michal
    Aug 23, 2021 at 19:45

I tried going to the panel's context menu > Panel Options > Add Panel > Application Menu Bar, but only an empty panel appears at the top of the screen.

If this happens to you:
1. Go to System Settings > Startup and Shutdown > Background Services, and then enable the Application Menus Daemon. Always remember to click Apply!
2. Restart any open applications.


In Kubuntu 20.04 (plasma 5.18.5) I have met exactly this: the global menus disappeared, and the entry in settings also (and this without me deleting any configs). I mean the button for global menus went away and no menus could be seen or enabled in applications.

It seems this is a rather old bug about the fact that adding window decoration menu button, makes in-app menu bars disappear. Also discussed here and here with solutions.

The absence of menus in settings was especially unpleasant (I had disabled menus in Konsole and Dolphin and now there was no way to enable them, not even by shortcut).

  • In order to restore the menus in settings, simply went to System Settings > Application Style > Windows Decorations > Titlebar Buttons and dragged that button down

enter image description here

  • In order to get it back, drag it back up, and see if it triggers the bug: it does in my case, so I won't do that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .